• "Field 'recordName' is not marked queryable" error when accessing cloud kit data

    I am trying to load a list from cloud kit and getting a "Field 'recordName' is not marked queryable". The record type list is queryable. The field recordName is a system generated field that I cannot modify in the clo...
    Profile Photo
    last modified by Ruppert20
  • How do I fetch all records in a record type?

    I want to fetch all records in a record type and then add them all to a picker view. Each record has a few indexes which i would like to access.
  • CKFetchRecordZoneChangesOperation and reference order of recordChangedBlock calls?

    Hi There,   I've been experimenting with CKFetchRecordZoneChangesOperation and have noticed that if I save two records that have a reference between them with CKModifyRecordsOperation, the next call to CKFetchRe...
    Profile Photo
    last modified by crafterm
  • Handling UIDocument.State editingDisabled

    Hi   Having made an app that allows users to save documents to iCloud Drive, I'm left with questions regarding the .editingDisabled state. My app calls open on the document and if the completion handler returns ...
    Profile Photo
    last modified by DiGiTaLFX
  • How do CloudKit containers handle app transfers?

    I’m slightly confused about how are CloudKit containers supposed to handle app transfers. I’m seeing some strange too-permissive security behavior, and I am not sure whether this is a feature or a bug ...
    Profile Photo
    last modified by Jaanus
  • CloudKit watchOS 6 silent notification problem

    Hello,   I watch the WWDC video regarding keep iPhone and independent watch app (watchos 6) in sync. So I have made a simple cloudkit subscription on the Apple Watch on a record (watch os 6).   1) On the ...
    Profile Photo
    last modified by And0Austria
  • WRITE operation not permitted on some record saves

    "My app is live on the app store using cloudkit, record saves are working except that sometimes I am getting "WRITE operation not permitted".  I can retry a couple of times, then it works.  Any one else expe...
    Profile Photo
    last modified by Jswiney
  • CloudKit is not working with Ad hoc and apps tore profiles.

    Integrated CloudKit to my application , In Debug mobe it is working properly , saving CKRecords to iCloud, updating and Fetching CKRecords are working In debug mode.   In release mode, above mentioned functional...
    Profile Photo
    last modified by sravanthihyd
  • Cloudkit Write Permission error for some records

    I have a Mac OS X app which has around 15 tables.  These have worked fine for multiple years. I am in development mode for this container.  I recently added a new table, adding it automatically as I created ...
    Profile Photo
    last modified by rschluet
  • "Permission Failure" (10/2007) - CloudKit

    Dears,   I have been used three apps that I developed almost 2 years ago and they share a same set of data offered by CloudKit.   Today, when I and my team tried to use such apps we identified that the fol...
    Profile Photo
    last modified by andrewdiniz
  • CloudKit: CREATE operation not permitted

    Hi,   I'm trying to use CloudKit Web Services to access my public database (development env.) I can read the records, when I try to use enpoint /records/modify I always get response that CREATE operation not per...
    Profile Photo
    last modified by krzyzanowskim
  • Watch simulator - sign into iCloud account

    Using Xcode 11. Can I sign a watch simulator into my iCloud account and, if so, how? By way of explanation, my app is Core Data + CloudKit and I would like the watch simulator to get the data that has been generated b...
    Profile Photo
    last modified by j4ke
  • Anyway to specify a unique constraint in Cloudkit record?

    I see in CKError.h there is an error: CKErrorConstraintViolation.   Is there a way to specify a unique constraint for a column in a CloudKit record?   The only part of a CloudKit record that enforces uniqu...
    Profile Photo
    last modified by Macho Man Randy Savage
  • CKModifyRecordsOperation, get change token afterwards

    After doing a CKModifyRecordsOperation, what's the suggested way to get the current change token? Since in most cases*, pushing changes won't cause a notification kickback and when there is a trigger to fetch changes,...
    Profile Photo
    last modified by JimmyCricket
  • Getting CKErrorServerRecordChanged error with no server record in userInfo. Instead there's an underlying error "SaveSemantics is failIfExists, existing record has chaining, new record does not"

    When I run my app and do a CKModifyRecordsOperation to save a record that already exists on the server (with no changetag) to test merging I do indeed get a CKErrorServerRecordChanged.   There is no values in th...
    Profile Photo
    last modified by Macho Man Randy Savage
  • upload offline changes on cloud with CloudKit

    CloudKit is the framework that powers iCloud on IOS I used this framework recently in a new project and i found it cool and easy to use but I had one issue and it's about offline mode when I have two devices A and B c...
    Profile Photo
    last modified by mrabi
  • How to fetch all long-lived operations on iOS

    Short summary When I create a long-lived CKModifyRecordsOperation on my iPhone while it is in airplane mode (no internet connection) then quit the application that created the CKModifyRecordsOperation by double tapp...
    Profile Photo
    last modified by damiaan
  • Cloud Kit not working after distributing app

    My app was working fine with Cloud Kit on the simulator but after I distributed it and sent it to the App Store it stopped working. When the users download the app they can not even log in. It is like the entities cre...
    Profile Photo
    last modified by bernardojn
  • Can't retrieve CKRecords to resolve conflicts on CKErrorCodeServerRecordChanged in CKModifyRecordsOperation

    I ran into some problem when trying to handle errors when doing batch operations on records in CloudKit. I am successfully extracting the dictionary containing the partial errors, which I can iterate over. However, I...
    Profile Photo
    last modified by hectique
  • User-preference-write or file-write-data sandbox access on Mac Catalyst using CloudKit

    I am working on adding support for macOS for one of my iOS and iPadOS apps.  I got everything working to the point that it would run but as soon as it tried to load the CloudKit data store it crashes with the rep...
    Profile Photo
    last modified by stephen11796