16 Replies
      Latest reply on Sep 11, 2019 3:06 AM by rlarsen
      qtzar Level 1 Level 1 (10 points)

        Looks like VMWare Fusion 11.1.0 is not working correctly on beta 1.

         

        The VM is running and I can see the screen in the VMWare Library thumbnail but the actual VM screen is black. The VM is reacting to mouse and keyboard and the interactions can be seen on the thumbnail.

         

        Tried in windowed, fullscreen and with 3d accelerated graphccs both enabled and disabled. I have also performed a full reinstall of VMWare Fusion.

        • Re: VMWare Fusion 11 Not Working
          James218 Level 1 Level 1 (0 points)

          I have same issue but it was telling me the file was damaged so i just went and got the newest version and installed it to fix it. I have an error saying "Could not open /dev/vmmon: Broken pipe. Please make sure that the kernel module `vmmon' is loaded."

          • Re: VMWare Fusion 11 Not Working
            paulr1 Level 1 Level 1 (10 points)

            VMware Fusion 11.1 is working for me.  I have to approve the kernal extention and added Screen Recording in the Priacy tab in Security & Privacy.

              • Re: VMWare Fusion 11 Not Working
                aholowka Level 1 Level 1 (0 points)

                Same here...added VMware kernal extension and screen recording and all is well.

                  • Re: VMWare Fusion 11 Not Working
                    PaulMJax Level 1 Level 1 (0 points)

                    Thanks for the suggestions, unfortunately still doesn't work.

                     

                    I Checked VMWare Kernel extensions (using 'kextstat | grep vmware') and all 4 are there. I don't have a Screen Recording entry in Privacy tab but I do have a Camera and Microphone and they are set to allow VMware Fusion.

                     

                    Using verbose option i see the following panic: "Unable to find driver for this platform: \"ACPI\".n"@/BuildRoot/Library/Caches/com.apple.xbs/Sources/xnu/xnu-6041.0.0.111.5/iokit/Kernel/IOPlatformExpert.cpp1994". There are then a lot of addresses and an interesting message "can't perform kext scan: no kext summary".

                      • Re: VMWare Fusion 11 Not Working
                        Solid Level 1 Level 1 (0 points)

                        You should have been prompted to allow screen recording the first time you tried to start a VM.  Without it the virtual console simply appears black, but if you look at the small preview of the virtual console in the list of VM's, you'll see that the VM came up and is running.  You have to quit and restart after allowing screeen recording for the virtual console to work.

                    • Re: VMWare Fusion 11 Not Working
                      qtzar Level 1 Level 1 (10 points)

                      Screen Recording was the answer for me here, I didn't have any issues with missing kexts.

                      Thanks.

                    • Re: VMWare Fusion 11 Not Working
                      oliversteffe Level 1 Level 1 (0 points)

                      I'm not sure if my problem is right placed here.

                      I'm running my host Mac with 10.14.5 (18F203).

                      In vmware Professional Version 11.1.0 (13668589) i have a virtual machine with macOS 10.14.5 (18F203).

                      I tried to Update it to macOS 10.15 Beta (Build 19A471t) But after the restart while updating I get only a black screen with a white Apple logo in the center of the screen.

                      Did anyone get it running? Is there a trick, or is ist simply a bug?

                      • Re: VMWare Fusion 11 Not Working
                        JuJuB Level 1 Level 1 (0 points)

                        I have the same issue when I'm logged in as my standard (non-admin) user, but it works fine when I'm logged in as an admin. Not ideal from a security standpoint since you should rarely be logged in as an admin, but it seems to be the workaround for now.

                        • Re: VMWare Fusion 11 Not Working
                          Zero_Kool Level 1 Level 1 (0 points)

                          In my case it was not listed in "Security & Privacy -> Screen Recording". After much searching and testing what worked for me is:

                           

                          1. Boot a VM with an OS that has VMware Tools installed (after the VM fully boots the ability to switch to Unity mode should be available)
                          2. Switch to Unity mode
                            • Keyboard command to enter Unity :     Shift-CMD-U
                            • Menu : View -> Unity
                          3. Upon switching to UNITY mode VMware Fusion will finally give you the dialogue box asking permission for Screen Recording
                          4. Click Open Preferences
                          5. Authenticate to make changes
                          6. Add the check mark to VMware Fusion to grant Screen Recording permission
                          7. Exit Unity mode

                           

                          Done

                           

                          Additional notes:

                          VMware may continues to go to Unity mode before you can select Open Preferences and give you white screens. The presentation is white because it has not been granted permission yet.

                           

                          From the VMware controls, shut down the VM gracefully. The Open Preferences should still be an open dialogue. Click Open Preferences and it will finally be visible in the list.

                           

                          For the adventurous, try resetting all of the TCC approvals for VMware Fusion and try again.

                          To reset the TCC, open a terminal and run the command:

                          tccutil reset All com.vmware.fusion
                          successfully reset All approval status for com.vmware.fusion

                           

                          This clears the Security and Privacy settings.

                           

                          Hope this helps.

                          • Re: VMWare Fusion 11 Not Working
                            GeorgeJT Level 1 Level 1 (0 points)

                            I think I accidently skipped the prompt to allow permission for Screen Recording. Now VMware isnt in the list under Settings/Privacy/Screen Recording. How do I get VMware in there?  Or get it to prompt me again to allow permission? Thanks.