32 Replies
      Latest reply on Aug 7, 2015 4:34 PM by gc.
      maurovc Level 1 Level 1 (0 points)

        Hi there,

         

        yesterday I installed the pre-release of OSX 10.11 and I can't open the Adobe Illustrator CS6.

         

        This is the error that I get:

         

        "Adobe Illustrator CS6" cannot be opened.

        This application requires the legacy Java SE6 runtime which is unavailable for this version of OS X.

         

        Thanks,

         

        Mauro Vime

        • Re: Java SE 6
          duncang Level 1 Level 1 (0 points)

          Me too, other Java apps also broken and when trying to reinstall Java 6 I get the following error:

           

          "Java for OS X 2014-001 can't be installed on this disk.  A newer version of this package is already installed."

          • Re: Java SE 6
            KaneHau Level 2 Level 2 (25 points)

            Confirmed.

             

            Installing SE 6 fails due to "newer version already installed"

             

            Trying to uninstall Java fails to uninstall it fully.

             

            Installing SE 8 (latest from Oracle) does not fix the problem.

             

            Also tried a full uninstall of Photoshop and reinstall, no better.

             

            ARUG!

            • Re: Java SE 6
              Level 1 Level 1 (0 points)

              Same here all the Adobe suite CS5 is not open becuase the not supported java version SE6. This needs to be fix Quickly! But is the an option to roll back to Yosemite?

              • Re: Java SE 6
                mafoe Level 1 Level 1 (0 points)

                Confirmed here, any workaround to fix this highly appreciated.

                  • Re: Java SE 6
                    djsharpe Level 1 Level 1 (0 points)

                    I think it has to do with the new system integrity protection feature. I was able to install it by booting into the recovery partition and running the command line installer from a terminal.

                  • Re: Java SE 6
                    dseitz Level 1 Level 1 (10 points)

                    Consider filing a bug report to Adobe. Apple is considering ending support for SE 6 after 10.11. See the release notes.

                    • Re: Java SE 6
                      suelicious Level 1 Level 1 (0 points)

                      Hi, i found a solution and it worked for me - try and google "Oliver Dowling" and "Java SE 8 on Mac OSX". There is a good instruction. Follow the steps, Illustrator and co are working right now, what a livesaver. I can't post a link in here, I tryied yesterday, but Apple still wants to "moderate" my comment.

                      • Re: Java SE 6
                        felixs Level 1 Level 1 (0 points)

                        I had Java 8 installed from Oracle under Yosemite and upgraded to El Capitan. If you haven't had it installed, you may try installing it first (be aware, though, that Oracle now ships it with adware, so you may want to look for instructions on how to install it without adware, first (IIRC the trick was downloading the .tar.gz file instead of the dmg file, but better look it up if you need it)).

                         

                        Now this worked for me:

                        1) boot from the Recovery Parition (hold down Cmd+R while booting)

                        2) use Disk Utility to mount the El Capitan system partition

                        3) use Terminal.app to create two folders:

                        mkdir -p /Volumes/[Name of volume]/System/Library/Java/JavaVirtualMachines/1.6.0.jdk

                        mkdir -p /Volumes/[Name of volume]/System/Library/Java/Support/Deploy.bundle

                        4) Unmount the volume (just to be sure)

                        umount /Volumes/[Name of volume]

                        5) Reboot and now Illustrator CS3 works as it did under Yosemite

                          • Re: Java SE 6
                            MattToner Level 1 Level 1 (0 points)

                            Thank you Felixs!

                            This worked perfectly.

                            Also gets Dreamweaver etc working too.

                            • Re: Java SE 6
                              Level 1 Level 1 (0 points)

                              Dumb question but how are you getting to terminal?

                               

                              When I boot into the recovery partition I only have 4 options: Restore from time machine backup, Reinstall OSX, Get Help Online, and Disk Utility?

                                • Re: Java SE 6
                                  Level 1 Level 1 (0 points)

                                  Hold down cmd-R while the machine is booting to enter Recovery Mode.

                                   

                                  When in Recovery Mode, select DIsk Utility and mount your system partition.  If you use FileVault, you will need to hit the unlock icon and type in your password to mount the partition. (weird, the forum is censoring the word u n l o c k.)

                                   

                                  Exit out of Disk Utility and back to the main Recovery Mode screen.

                                   

                                  At the top, under the Utilities menu, choose Terminal.

                                   

                                  In Terminal, run the commands felixs suggested, above.

                                   

                                  After you have run the mkdir commands and unmounted your parition, type "reboot" to reboot the system.

                                   

                                  (Thanks for the tips, Felix.  Worked great here for me.)

                              • Re: Java SE 6
                                Level 1 Level 1 (0 points)

                                I was able to roll back to Yosemite by doing the following:

                                1. Boot into the recorvery partition (CMD + R)

                                2. Go to Utilities in the top Menu Bar

                                3. Go to Security Settings

                                4. Uncheck 'Enforce System Integrity Check'

                                5. Reboot

                                6. Go into your installed apps and run the Yosemite installer

                                 

                                Hope that helps

                                • Re: Java SE 6
                                  KaneHau Level 2 Level 2 (25 points)

                                  As mentioned by suelicious, the web article by Oliver Dowling gives the following solution.  I did this and it allowed Photoshop to run!

                                   

                                  Download the latest Java from Oracle and then...

                                   

                                  Here is the steps I did:

                                   

                                  The solution is to edit /Library/Java/JavaVirtualMachines/jdk1.8.0_45.jdk/Contents/Info.plist and change:

                                   

                                  <key>JVMCapabilities</key>

                                  <array>

                                      <string>CommandLine</string>

                                  </array>

                                   

                                  To:

                                   

                                  <key>JVMCapabilities</key>

                                  <array>

                                      <string>CommandLine</string>

                                      <string>JNI</string>

                                      <string>BundledApp</string>

                                  </array>

                                   

                                  - Save the changes and start up Photoshop - no problems!

                                   

                                  NOTE... depending on what JDK you have loaded, you will need to change the 'jdk1.8.0_45.jdk' to whatever you have loaded.

                                   

                                  To figure that out, simply look at what is in /Library/Java/JavaVirtualMachines/

                                  • Re: Java SE 6
                                    mydevelacc Level 1 Level 1 (0 points)

                                    Got it working

                                     

                                    1.

                                    Download the Java SE 8 DMG from http://www.oracle.com/technetwork/java/javase/downloads/jre8-downloads-2133155.html and install.

                                    2.

                                    In Terminal enter the following to turn off rootless and then reboot: sudo nvram boot-args="rootless=0"

                                    3.

                                    In Terminal enter these 2 lines: sudo mkdir -p /System/Library/Java/JavaVirtualMachines/1.6.0.jdk


                                    4.

                                    sudo mkdir -p /System/Library/Java/Support/Deploy.bundle


                                    5.

                                    Turn rootless back on and reboot again: sudo nvram boot-args="rootless=1"

                                     

                                    Enjoy!

                                      • Re: Java SE 6
                                        gc. Apple Staff Apple Staff (255 points)

                                        The supported way to disable System Integrity Protection in those cases where it's truly necessary is to boot into the Recovery partition and turn System Integrity Protection off from there with the csrutil tool.

                                         

                                        $ csrutil

                                        usage: csrutil <command>

                                        Modify the System Integrity Protection configuration. All configuration changes apply to the entire machine.

                                        Available commands:

                                            disable

                                                Disable the protection on the machine. Requires a reboot.

                                            enable

                                                Enable the protection on the machine. Requires a reboot.

                                            status

                                                Display the current configuration.

                                         

                                        The kext-dev-mode and rootless boot-args are being removed from OS X El Capitan and will no longer work.

                                         

                                        --gc

                                      • Re: Java SE 6
                                        gajahduduk Level 1 Level 1 (0 points)

                                        Ouch. These solutions are not pretty. But apparently they would be necessary. The Adobe CC products are certainly not the only ones I use that require Java 6. It would be so much better if there were more attention from Apple developers on maintaining compatibility with legacy software that is commonly used.

                                        • Re: Java SE 6
                                          JMaynard Level 1 Level 1 (0 points)

                                          Tried all the suggestions in this thread to no avail.

                                           

                                          Simplest and easiest is to install Apple's Java developer kit. Go here to download it: https://goo.gl/J8Wi3

                                           

                                          NOw have Dreamwraver running on El Capitan...