3 Replies
      Latest reply on Feb 27, 2018 7:09 AM by www0488
      www0488 Level 1 Level 1 (0 points)

        Hello guys, right now i'm trying to build a basic AR app. to test some of the function. But when i tried to start my application, it gets frozen for no reason and i got the error message :

         

        UserInfo={NSLocalizedFailureReason=A sensor failed to deliver the required input., NSUnderlyingError=0x1cc049cf0 {Error Domain=CMErrorDomain Code=101 "(null)"}, NSLocalizedRecoverySuggestion=Make sure that the application has the required privacy settings., NSLocalizedDescription=Required sensor failed.}

         

        I did some research and find out it might be course by GravityAndHeading. but the strange thing is when i tried to use another iphone X device and run my application, it worked pretty well. After that i compared all general setting and privacy setting for both iphone x device and both of them have exactly same setting!


        Also i did review some old post : https://forums.developer.apple.com/message/285212#285212
        I tested disable compass heading orientation and restarted both my mac and iphone x device, but still can't make the application works correct.

        Is there anyone who have the same issue? Please help me >.<