21 Replies
      Latest reply on May 8, 2020 8:52 AM by peaura
      Adalex3 Level 1 Level 1 (0 points)

        I am simply trying to run my app on my iPad through lightning cable but I am getting this strange error:

         

        Could not launch "[App Name]"

        [Device name] denied the launch request

         

        I have looked all over the internet for an answer to this but cant seem to find a good solid fix.

         

        I have tried everything from deleting the app on my iPad to cleaning the project to restarting many times but nothing will work. Right now I am running Xcode 9 beta so I tried switching to Xcode 8.3.3 and testing it there. I get a different error:

         

        Could not launch "[App Name]"

        process launch failed: Unspecified

         

         

        Next, I tried doing it on the simulator to see if it was any different. The outcome was a continuous loop of the app opening and crash, then opening again, and crashing again. After about five minutes of this loop, I got this error:

         

        The request to open "com.hp.Goal-Tapper" failed.

        The request was denied by service delegate (SBMainWorkspace) for reason: Unspecified.

         

        Does anyone know how to fix this? I am a beginner at Xcode and swift so I won't know very complicated things. Thanks in advance. Any help is appreciated.