6 Replies
      Latest reply on Jul 9, 2018 11:08 PM by redDree
      PMBO Level 1 Level 1 (0 points)

        To whom it may concern,

         

        My project is applied the newest framework - ARKit, which is based on Xcode9 beta5(the newest version), iOS11, and iPhone 6s + supported.

        But I've recently being unable to upload archives compiled with Xcode9 beta5 to iTunes Connect. The errors I'm getting are the following:

        Invalid sdk value. The value provided for the sdk portion of \ LC_VERSION_MIN_IPHONEOS in MyApp.app/MyApp is 11.0 which is greater than the \ maximum allowed value of 10.3.

        The value provided for the sdk portion of \ LC_VERSION_MIN_IPHONEOS in MyApp.app/MyAppex/MyWidget  is 11.0 which is greater than the \ maximum allowed value of 10.3.

        Is it that the Xcode 9 beta5 could not be used for publishing version? But the formal version of Xcode 9 has not been updated yet.

        Or, I should use the Xcode 8.3.3 to upload archives? But the Xcode 8.3.3 can not support the ARKit.

        Could you please tell me some advice to solve above issue?

         

        Thank you for your time.

        • Re: LC_VERSION_MIN_IPHONEOS
          TonyPham Level 2 Level 2 (80 points)

          I simply used default settings which XCode (9 beta) generated with ARKit template and I could upload my app to iTunes Connect (for testing) without any trouble. The default deployment target is 11 but there is no settings with LC_VERSION_MIN_IPHONEOS.

            • Re: LC_VERSION_MIN_IPHONEOS
              PMBO Level 1 Level 1 (0 points)

              Is that  you mean the demo you uploaded is just for testing (use the testflight) ,not for production? Is it could not be publish for production now?

              Otherwise, I could upload my app to iTunes Connect successfully,but  when I clicked the submit for review button , the operation loged :

              1.When building new apps and App updates, you must use public (GM) Xcode 6 or later, macOS, and iOS SDK. Please do not submit a Beta version of the App, including a Beta version of macOS.

              2.Invalid sdk value. The value provided for the sdk portion of \ LC_VERSION_MIN_IPHONEOS in MyApp.app/MyApp is 11.0 which is greater than the \ maximum allowed value of 10.3.

              3.The value provided for the sdk portion of \ LC_VERSION_MIN_IPHONEOS in MyApp.app/MyAppex/MyWidget  is 11.0 which is greater than the \ maximum allowed value of 10.3.

              I wander  that Is it  the Xcode 9 beta5 could not be used for publishing version to production ,just can test?

              Should we wait the the formal version of Xcode 9 published ,then we can publish our apps with ARKit Framework?

              And ,the LC_VERSION_MIN_IPHONEOS setting I can not find in Xcode.

              Finally,Thank you for your time.

                • Re: LC_VERSION_MIN_IPHONEOS
                  KMT Level 9 Level 9 (12,525 points)

                       >I wander  that Is it  the Xcode 9 beta5 could not be used for publishing version to production ,just can test?

                   

                  Yes.

                   

                       >Should we wait the the formal version of Xcode 9 published ,then we can publish our apps with ARKit Framework?

                   

                  Yes. Beta tools cannot be used to build and submit apps to the store for distribution.

              • Re: LC_VERSION_MIN_IPHONEOS
                ingconti Level 1 Level 1 (0 points)

                my two cents:

                I use Xcode 9 and got:

                 

                he value provided for the sdk portion of \ LC_VERSION_MIN_IPHONEOS in MyApp.app/MyApp is 11.3 which is greater than the maximum allowed value of 11.2.

                 

                It was due to a build using Xcode 9.2 beta that leaves its data in DerivedData.

                So cleaning DerivedData solves the issue.

                • Re: LC_VERSION_MIN_IPHONEOS
                  hiDemo Level 1 Level 1 (0 points)

                  I'm very disappointed with Apple way, Why Apple suggest us to download upper version 5GB, Which it doesn't support it yet on Apple Store