24 Replies
      Latest reply on Jan 26, 2017 6:31 AM by rrSimon
      Level 1 Level 1 (0 points)

        If you search for IdentifierForVendor on the old forum, you get a couple of hits of people telling that is has changed unexpectedly.

         

        Can apple please confirm that there is/was an issue with this, in the period end may / beginning june.

         

        We hypothesize that changes to our provisioning profiles (adding app groups for apple watch integration) has triggered a change in the value of identifierForVendor on update. However, we are still in the process of validating this hypothesis.

         

        Has anyone had the same issue? Were there changes in your provisioning profile? How were you impacted?

        • Re: IdentifierForVendor changed unexpectedly + forum is broken
          stain Level 1 Level 1 (0 points)

          Hi jero

           

          We had exactly the same problem with an app that has been published for sale on June 6. Several updates of the app before that date kept the identifier. Now all our users got a new identifier, which breaks our device verification.

           

          I would be very interested if this is a one time problem or if this change is permament.

           

          I made no major change on the provisioning profile recently.

          • Re: IdentifierForVendor changed unexpectedly + forum is broken
            agavric Level 1 Level 1 (0 points)

            Hi jeroentrappers

             

            We appear to be having the same issue as well.  App published on June the 9th, no profile changes, only difference to previous releases was the build machine changed.

            Interested to find out more.

            • Re: IdentifierForVendor changed unexpectedly + forum is broken
              DHOscar Level 1 Level 1 (0 points)

              Hi,

               

              The same problem here. Would like to know if it just one time thing for new devleoper programm update or something is broken.

               

              Also, does any body do the distribution after that time slot? Dose the IDFV change again?

              • Re: IdentifierForVendor changed unexpectedly + forum is broken
                Nordcurrent Level 1 Level 1 (0 points)

                Yes, there is a problem with this. We have written about this in the old forum, and have reported a bug (which has been marked as a duplicate and closed). Would be great to hear from Apple about this. Is it going to be fixed, and if so - when? Or should we look for alternative solutions

                • Re: IdentifierForVendor changed unexpectedly + forum is broken
                  jorgmart Level 1 Level 1 (0 points)

                  Hello,

                   

                  We are experiencing this issue too with many users. Can you confirm if this is related just to iOS 8.3? Do you have cases with any other iOS versions?

                   

                  When did you start to experience the issue? We have several days with these problems (maybe one or two weeks), I don't know what caused it because iOS 8.3 came out more than 2 months ago (April 8th). Any ideas?

                   

                  By the way, I sent a bug report to.

                   

                  Regards.

                    • Re: IdentifierForVendor changed unexpectedly + forum is broken
                      Jbmechanic Level 1 Level 1 (0 points)

                      We have seen this too. Without researching too much about it yet, this is what happened: For a new app we work on, we realized that identifierForVendor no longer works as advertised in the documentation. So the feature we were gonna use it for, well, we leave that feature out of this new app for now. We also confirmed the problem exists in a live app which we released a few weeks ago. The same feature is there, and also in most apps we created the last two years. I just assumed all of that broke because of the problem with identifierForVendor, but some of you guys believe this is just a problem with iOS 8.3, or recently released/updated apps?

                        • Re: IdentifierForVendor changed unexpectedly + forum is broken
                          fmccardoso Level 1 Level 1 (0 points)

                          We've seen this happening in different OS versions (from 7.1.2 to 8.3) and differente devices (iPhone4 to 6).

                           

                          From our tests, that included hard reset an iphone and installing 2 apps from the same vendor (repeated several times), the results were completely random: some times everything worked fine, sometimes the second app wouldn't get the same IDFV and even after uninstalling only one of them, the other would stop having the same IDFV.

                           

                          This doesn't seem to be related to the OS version I'm afraid, I suspect xcode (I think this all started happening after the last update, but I can't be sure) or something in iTunes Connect when they're "cooking" the final ipa for the store.

                            • Re: IdentifierForVendor changed unexpectedly + forum is broken
                              MJ Mechanic Level 1 Level 1 (0 points)

                              We have this problem too. 

                               

                              I believe this is not really related to iTunes Connect, just because this used to work in an adhoc-only IPA setting during development testing - where we only used the old TestFlight ie ipas that never touched iTunes Connect yet. Now it also stopped working during testing. So the problem might be with the latest iOS 8.x... which would mean that the problem is more inside Xcode or iOS 8.x... but if you say that the problem appears on 7.x then I guess only Apple knows the answer.

                        • Re: IdentifierForVendor changed unexpectedly + forum is broken
                          Jamie Mellway Level 1 Level 1 (0 points)

                          We are seeing this.  If we download the app from the AppStore, we're only recently seeing different IdentifierForVendor values, but if I take those same IPA files and add it to iTunes, the values are the same.  If we get our most recent versions of the apps from iTunes Connect, the values are the same.  It only seems broken if we get the apps from the AppStore.  Our submitted apps were built using Xamarin iOS 7.0.5.2 and XCode 5.0.2.

                           

                          The documentation says this about identifierForVendor: "Normally, the vendor is determined by data provided by the App Store. If the app was not installed from the app store..."  It then goes on to explain how identifierForVendor works for non-AppStore deploys, but not how it works when it is downloaded from the AppStore.

                           

                          From this question on StackOverflow,  I suspect that the AppStore version of the IdentifierForVendor is now based on the provisioning profile.  We are using unique provisioning profiles on each app rather than using a wild card provisioning profile.  Until I found this thread, I was thinking that if I resubmit our apps to the store using a wild card provisioning profile and the latest XCode it would fix this, but now I'm doubtful.

                           

                          Has anyone come across a workaround?  Is there any visibility on the bugs already submitted to Apple?

                          • Re: IdentifierForVendor changed unexpectedly + forum is broken
                            fmccardoso Level 1 Level 1 (0 points)

                            I've just checked my bug report, which was marked as Duplicated and it now says that the original bug is closed. This sounds as good news, but does anyone has more details? What whas fixed and where? Connect, xcode, SDK, iOS?

                            Some more information from Apple would really be useful as this bug caused some severe problems with our apps and we need to explain what happened to our clients.

                              • Re: IdentifierForVendor changed unexpectedly + forum is broken
                                MJ Mechanic Level 1 Level 1 (0 points)

                                I'm checking with a live app which uses this feature.

                                 

                                iOS 8.3 device: not fixed, problem still there, ID change between installs where other apps of us are still on device

                                iOS 8.4 device: not fixed, problem still there, ID change between installs where other apps of us are still on device

                                 

                                 

                                So it's not fixed even in iOS 8.4. MAybe this won't get addressed until iOS 9??

                                • Re: IdentifierForVendor changed unexpectedly + forum is broken
                                  SHB Level 1 Level 1 (0 points)

                                  I've also submitted a bug for the identifierForVendor problem and Apple replied (08-Jul-2015) that this "issue" has been addressed in the latest iOS 9 beta. Made some quick tests and it seems like our app are receives the same identifierForVendor on devices using iOS9 Beta, at least when we are updating the app using promo-codes. Have someone else received the same answer and been able to comfirm that identifierForVendor remains intact when using the latest release of iOS9 Beta?

                                • Re: IdentifierForVendor changed unexpectedly + forum is broken
                                  ale Level 1 Level 1 (0 points)

                                  What's even worst with this is that if you have iCloud with CoreData your users have a huge risk of losing data.

                                   

                                  CoreData stack with iCloud creates a folder named "mobile~_identifierForVendor_" where it puts the sqlite file. On app update, the identifierForVendor changes, and a new sqlite gets created with a different path: this isn't a big deal as far as users had enabled iCloud, the data would just get downloaded again. However, if the users DOESN'T have iCloud enabled, this is a mess because the old file cannot be found anymore, and data is there but unavailable.

                                   

                                  I wrote to the technical support and they told me that this is a known issue, it shouldn't happen and it was going to be fixed server-side

                                   

                                  Anyone else is having the same issue?

                                  • Re: IdentifierForVendor changed unexpectedly + forum is broken
                                    Mick at We Make Apps Level 1 Level 1 (0 points)

                                    We're definitely seeing the same behaviour, across a range of different devices. It only seems to happen for a minority of users when updating the app. But it is clearly happening. There's no ad hoc or other install methods going on; users are definitely just updating, not deleting and re-installing. It's very frustrating that this feature does not work as documented.

                                    • Re: IdentifierForVendor changed unexpectedly + forum is broken
                                      gc. Apple Staff Apple Staff (255 points)

                                      There was an issue recently where apps were being given an incorrect identifierForVendor when they were installed or updated. This was a bug that was introduced near the beginning of May. Around July 21, the App Store completed the process of restoring the identifierForVendor of apps that experienced this bug to the value it had before the bug was introduced.

                                       

                                      Apps that were installed or upgraded while this bug was present will see one more identifierForVendor change the next time the user updates or reinstalls the app after about July 21 but it will be a value the app had used before. (The data used to compute identifierForVendor is delivered along with app installations or updates.)

                                       

                                      IMPORTANT: This means that you may get random reports about this issue because it only appears when the user updates your app.

                                       

                                      If you haven't updated your app since about July 21, you may want to consider shipping an update of your app so the user can perform an update without removing your app and thus losing data. This update wouldn’t have to have any different functionality.

                                       

                                      There should be no further identifierForVendor changes once a user updates your app after about July 21 unless the user removes all of your apps and then reinstalls one of them, or if they restore their device from a backup created on a different device. These are the documented cases where identifierForVendor is expected to change.

                                       

                                      If you see any behavior other than what I’ve described, please file a bug report about it at <https://developer.apple.com/bug-reporting> so we can investigate.

                                        • Re: IdentifierForVendor changed unexpectedly + forum is broken
                                          ale Level 1 Level 1 (0 points)

                                          @gc just to know, can you confirm that this problem have also affected CoreData + iCloud support, due to mobile~<identifierOnVendor> folder changes on updates, and that now it is solved too?

                                          • Re: IdentifierForVendor changed unexpectedly + forum is broken
                                            rrSimon Level 1 Level 1 (0 points)

                                            I'm sorry to revive such an old thread but we're currently having issues with our app updates that relate to this. We have updated 3 of our apps last november and, since then, our testing has been reporting bugs relating to identifierForVendor changing. Even when testing with TestFlight updating over an AppStore build, I am noticing the id being different. This behaviour has never been noticed before by QA so I'm worried releasing an update might break certain identifierForVendor-dependant features for our current userbase.

                                             

                                            Have you had reports about this lately from other developers? What could have caused this change? We have many other of our apps installed on our devices so there is no reason why it would reset for our updates.


                                            EDIT: I forgot to mention that our application has iCloud support and we're seeing this when iCloud is disabled on the device. Could this be related?


                                            Thanks