2 Replies
      Latest reply on Jan 7, 2016 11:40 AM by kolpanic
      JonB-Feral Level 1 Level 1 (0 points)

        Is anyone else having a problem trying to install and authenticate sandboxed apps in 10.11.2?

         

        Ive just got this feednback form one of my testers so im interested to know ifd anyone else is seeign the same thing.

         

        If a live account is not signed into the AppStore, the AppStore is then launched, test account details are not accepted and application cannot be authenticated.

         

        If a live account is currently signed into the AppStore when authenticating the application, a separate sign in box is displayed. Entering sandboxed test account details into the box presents a notification that AppleID has not been used with the AppStore and will need to be reviewed.

         

        Selecting to review redirects the user to the AppStore and a session timed out page.

         

        -------

         

        We can roll back to 10.11 ot boot into a 10.10.5 partiton to install and authenticate apps but this is a big screw up on apples part if this is legit.

        • Re: Unable to authenticate apps in 10.11.2
          moondog Level 1 Level 1 (0 points)

          Same here. I get the message that the app is damaged and should be reloaded from the App Store (which is pointless, of course, when developing).

            • Re: Unable to authenticate apps in 10.11.2
              kolpanic Level 1 Level 1 (0 points)

              I was struggling with this one today too—both my machine and a QA tester's got the damaged app alert, but on another dev's, it worked fine. I finally got it working. In case it helps someone else, here's what worked for us.

               

              I used Activity Monitor to force-quite the following processes: storeaccountd, storeassetd, storedownloadd, and storeinappd. Then, I deleted the corresponding folders in ~/Library/Caches/. Finally, I rebooted. It didn't fix anything initially, but after a few minutes, it started working—we could log in to our purchase-testing AppleIDs and get receipts.