13 Replies
      Latest reply on Dec 11, 2019 11:09 PM by wqw
      gbros Level 1 Level 1 (0 points)
        In-app purchase is not working in the version of the app downloaded through the store.  This works perfectly in the test-flight version.
        You see that the price is (null) and then the purchase itself doesn't go through. When creating the app in itunesconnect there was no option to add in-app purchase to the app in the main developer page as detailed in page 22 of the manual here:
        https://developer.apple.com/library/ios/documentation/LanguagesUtilities/Conceptual/iTunesConnectInAppPurchase_Guide/iTunesConnectInAppPurchase_Guide.pdf
        It all works perfectly in the sandbox. I even tried developer rejecting the review, to see if that would help as per this:
        http://stackoverflow.com/questions/10366184/in-app-purchases-cannot-be-added-to-this-version-because-it-has-already-been-sub
        It did not help.
        Is the document out of date? Am I doing something wrong? I have resubmitted a new app with new features as well as a different in-app purchase to see if we can get more debug info or if it will just start working.

        There’s this also, which means we may just need to be patient.  http://stackoverflow.com/questions/6355442/in-app-purchase-not-working-in-released-version

        • Re: in-app purchase not working in store version
          PBK Level 7 Level 7 (3,365 points)

          First, you often need to wait 24 to 48 hours after approval for the IAPs to come on line.

           

          But you wrote..."When creating the app in itunesconnect there was no option to add in-app purchase to the app".  This option should appear immediately after you add a'screenshot' to the IAP.  Did you add a screenshot to each IAP?  If you did not select IAPs for inclusion with your binary then you have not submitted them for approval.  IAPs that have not been submitted for approval and approved will work in the sandbox environment in test flight and on the simulator but will not appear in the production environment.

          • Re: in-app purchase not working in store version
            slain Level 1 Level 1 (0 points)

            How long or how did you manage to solve this issue?

             

            I'm having this issue right now as well. Only 3/8 iAP products are properly loaded 30 hours after the app has been released. ONLY in production version. I'm based in northern Europe, it might work fine in the US.

             

            This is only happening in production version. Test versions, Google Play all work as they should.

            • Re: in-app purchase not working in store version
              yaroslav_ya Level 1 Level 1 (0 points)

              For the next who will face this issue.

              I'd met same issue now. And it takes for me up to 54 hours after app approval to purchases becomes online. But in the end everything's fine, they all online now. But definitely not best experience for me.

              • Re: in-app purchase not working in store version
                Apps Places Level 1 Level 1 (0 points)

                My approved in app purchases have worked inside live app after 67 hours from "Ready for sale". I'm really frustrated for such a long time, Apple should do something about this issue, it's 2019 but we are facing this issue yet

                • Re: in-app purchase not working in store version
                  JSMilton Level 1 Level 1 (10 points)

                  Currently going through this myself now. It's an absolute farce and really embarrassing for a company of Apples stature to have such inadequte infrastructure. Been waiting 6 hours now and I have quite a few people enquiring what is going on. It's a shocking customer exeprience. It just works, right? These reports of 50 - 60 hours are very concerning for me. Apple, fix your s**t.

                   

                  EDIT:

                  20 hours now and still nothing. This is absolutely ridiculous and it's costing me sales. Anyone from Apple fancy commenting on this? Do you think it's an acceptable experience for your users and devs? Also, why aren't we warned that this can happen before creating the IAP? Having the info buried in a tech note doesn't count.

                   

                  EDIT 2:

                  33 hours in and the wait continues. The best thing is that I'm now receiving 1 star reviews because the IAP doesn't work! Thanks Apple...