0 Replies
      Latest reply on Oct 21, 2019 12:22 AM by yaroslav_p
      yaroslav_p Level 1 Level 1 (0 points)

        An application is removed from "Full Disk Access" view of the Privacy tab (Security and Privacy pane) after upgrade to macOS 10.15.1 beta 2.

         

        I installed our application on Catalina (10.15) . Had clicked .pkg file from Finder to install it. The service from it  (LaunchDaemon) tried to access protected folder and it was shown in "Full Disk Access" view. I put a tick to give access for the application. Everything worked fine.

        But after upgrade to macOS 10.15.1 Beta 2  my service is not visible in "Full Disk Access" view. But the service has access to protected folders. I checked that. If I re-run our service bundle (using 'open') it becomes visible in "Full Disk Access" view (with a tick).

         

        Our service bundle resides in /Library/Application Support folder. I suppose that macOS does not handle properly bundles in that folder.

         

        Does anybody have similar problem? How do you solve it?

         

        Regards,

        Yaroslav