0 Replies
      Latest reply on Oct 2, 2019 2:40 PM by kPas42
      kPas42 Level 1 Level 1 (0 points)

        I have had a published universal app for many years that has worked fine.  Now since the iOS13 update it simply starts to a solid white screen.  The only exception is if I run it on an iPad and change orientation of the device.  Than the app finally appears as it always has.  I have placed a breakpoint in my delegate file in the Application method and another in my rootviewcontroller in the viewDidLoad method.  In iOS 12 both breakpoints get hit and everything runs as it always has.  In iOS 13 the rootviewcontroller breakpoint never gets reached.  The app is very old and uses plain old XIB files with no Storyboards.

         

        The code in my delegate is this;

         

        #import "AppDelegate.h"

        #import "RootViewController.h"

         

        @implementation AppDelegate

        @synthesize window, splitViewController;

        @synthesize managedObjectContext = _managedObjectContext;

        @synthesize managedObjectModel = _managedObjectModel;

        @synthesize persistentStoreCoordinator = _persistentStoreCoordinator;

         

        - (BOOL)application:(UIApplication *)application didFinishLaunchingWithOptions:(NSDictionary *)launchOptions {

         

            [self.window setRootViewController:self.splitViewController];

            [self.window makeKeyAndVisible];

            return YES;

        }

         

        Any help would be greatly appreciated.