9 Replies
      Latest reply on Aug 3, 2019 2:05 PM by idomo
      idomo Level 1 Level 1 (0 points)

        Having this issue since beta 3 came out and hoped that beta 4 will fix this, but it didn't.

        Every time I'm opening Main.storyboard in xCode, I'm getting the death wheel (colorful endless spinning wheel) with the error "An internal error has occurred editing functionality may be limited".

        The only option I have is to "Quit immediately", but when opening xCode again, it loads the storyboard since is the last file I've opened, so the only way to be able to use xCode at all is to go to the project directory, right click on the .xcworkspace file, click "Show package contents", locate the file "UserInterfaceState.xcuserstate" and delete it.

        Only after deleting this file I'm able to use xCode as normal as possible and of course, the storyboard is still not accessible.

         

        Well, I've reported to Apple via the Feedback Assistant and via the email and also updated them that it happens also in beta 4, but it doesn't seems like anyone cares about it.

         

        It doesn't seems to happen with any other storyboard file from other projects and the launch screen file, it's only in this specific file, but the exact same file (without any changes) was working perfectly with xCode beta 2.

         

        Also, since this issue has begun, some specific ViewController's localization stopped working(?), it's just showing this specific one in English (base) translation while the whole app is showen in anouther language (the device's/simulator's main language, it happen on both iOS 12 & 13), maybe it's related some how?

         

        * Tried everything from restart the Mac to deleting Derived Data (several times), went all over google (this forum, stackoverflow and some more places) - nothing helps.

        This is the closest description to my issue, that of course, doesn’t have any helpful answer.

        * The app is running fine on real device/simulator with iOS 12/13 (respectively).

        *I have xCode 10.2.1 installed, but can't open the project or the storyboard there 'cause I've adopt iOS 13 color scheme that doesn't supports there.

        * Using macOS 10.14.4 (18E226)

         

        Any suggestions? I'll really appreciate any kind of help.

         

        The storyboard file (remove the spaces around "google"):

        drive. google .com/file/d/10ynwU7mtTIUE8pW2Ud4dHtSAzJTv5vEc/view