2 Replies
      Latest reply on Apr 29, 2019 9:00 PM by rdselle
      hansung2 Level 1 Level 1 (0 points)

        I don't know why

         

        we make AASA file ( contentType : application/json ) except .json and paths TeamID.BundleID

         

        deployment target : 9.3

        associated domians : applinks:stg-mt.syrup.co.kr:7779

        AppId : associated domains enable

        and then download provisioning profile

         

        Device consol log also good

        16:06:18.469714 +0900 swcd Started request for domain 'stg-mt.syrup.co.kr:7779', URL 'https://stg-mt.syrup.co.kr:7779/.well-known/apple-app-site-association'

        16:06:18.814078 +0900 swcd Completing request for 'https://stg-mt.syrup.co.kr:7779/.well-known/apple-app-site-association', status 0/0x0 noErr

         

        but

         

        16:06:18.819946 +0900 nsurlsessiond [759 <private> stream, bundle id: com.apple.swcd, pid: 110, url: https://stg-mt.syrup.co.kr:7779/.well-known/apple-app-site-association, tls, indefinite] cancelled

        [759.1 72C4E481-96BB-42F0-BEDE-C0F4338A66F7 <private>.50829<-><private>]

        Connected Path: satisfied (Path is satisfied), interface: en0, ipv4, dns

        Duration: 0.202s, DNS @0.005s took 0.016s, TCP @0.028s took 0.019s, TLS took 0.084s

        bytes in/out: 5701/588, packets in/out: 6/3, rtt: 0.015s, retransmitted packets: 0, out-of-order packets: 0

         

        i don't know why 'cancelld' ? related that does not work?

        • Re: universal links not working
          heidji Level 1 Level 1 (0 points)

          same error dude, have you figured it out in the end? much obliged

          • Re: universal links not working
            rdselle Level 1 Level 1 (0 points)

            I'm seeing the same thing.  Other issues that I have found searching around and see for the .well-known path on my own are clearly logged.  For example:

             

            ### Bad apple-app-site-association JSON: Error Domain=NSCocoaErrorDomain Code=3840 "JSON text did not start with array or object and option to allow fragments not set." UserInfo={NSDebugDescription=JSON text did not start with array or object and option to allow fragments not set.}

            ### Download URL 'https://<domain>/.well-known/apple-app-site-association' failed: -6717/0xFFFFE5C3 kFormatErr

             

            That makes perfect sense because I do not have the file at .well-known.  Generic HTML for a "page not found" page is returned.  I do have the file at root and am seeing the exact same thing for that request- 0/0x0 noErr followed by an unexplained cancellation.