7 Replies
      Latest reply on Aug 9, 2018 7:12 AM by kballestrini
      sulliops Level 1 Level 1 (0 points)

        Hi all, I'm running iOS 12 Developer Beta 2 on my iPhone 7 (CDMA) and my watch (1st generation, not series 1) is running watchOS 4.3.2 Beta 3. Yesterday Beta 4 for watchOS 4.3.2 was released and I've been trying to update, but nothing will work. The "1" icon shows up in the Apple Watch app, but when I click on Software Update, it gives me this error.


        Could Not Connect to Apple Watch

        Make sure your Apple Watch is nearby, powered on, and not in Airplane Mode.


        This is incorrect, because my watch is nearby, powered on, on the charger in fact, and not in Airplane Mode. I've tried restarting both devices, tried wearing the watch, tried disabling auto-lock, tried using cellular on my iPhone to check for updates, and nothing. I actually did manage to check for updates once before this issue started, but it gave me an error saying the connection to the software update server couldn't be established.


        Initially, I thought this could be because I'm running iOS 12. However, I was able to update the watch to 4.3.2 Beta 3 (the one it's currently running) a couple weeks ago while running iOS 12, so if the issue has to do with either of the betas, it's the most recent one.


        Also, in case it makes any difference, I've noticed that notifications aren't being sent to my watch properly. I don't know when it started, but at some point they stopped working. At least, the notifications get sent but they only appear if I tap the moment they're received — after that, they don't show up in the notifications screen on the watch. I was thinking this could be a symptom of the watch and the phone not connecting properly, which would explain the difficulty with updating, but it still makes me ask how it's happening.


        If anyone has had this problem (or is currently having the problem), let me know what you did to solve it. I really don't want to have to unpair the watch because I run the risk of encountering issues with pairing that are related to this problem. If any Apple staff can look into this issue, that'd be great — and if they do, they should really tell someone to test these things ahead of time, because none of this shows up anywhere in the release notes.



        • Re: Cannot Update Apple Watch
          sulliops Level 1 Level 1 (0 points)

          Hi, made a mistake but cannot edit the post for some reason. The watch is running watchOS 4.3.2 Beta 2, trying to update to Beta 3.

            • Re: Cannot Update Apple Watch
              barrykn Level 1 Level 1 (0 points)

              Me too on the "Could Not Connect to Apple Watch" problem when trying to update to the latest watchOS 4.3.2 beta on my original Apple Watch ("Series 0" as people call it). I don't believe I'm having any notification problems, but I think I've had fewer notifications than usual over the past several days, just by pure coincidence, so I can't be absolutely certain right now that my notifications are working 100% properly.


              The next troubleshooting step I'm considering is unpairing and repairing the watch, or possibly unpairing then temporarily pairing to a different iPhone running iOS 11.4.x to see if that phone can update the watch. I don't know when I'll get a chance to try that, however.

            • Re: Cannot Update Apple Watch
              donavon Level 1 Level 1 (10 points)

              So I was having the same issue getting my watch to update. My iPhone kept saying it couldn't connect to the watch, even though they were connected just fine. I had tried multiple reboots of both devices and even unpairing and re-pairing the watch. Nothing worked. I decided to try installing the watch beta profile on my phone, in addition to already being on the watch itself, even though I know that's not how that's actually supposed to work. Odd thing though, it did work. Lol. The watch profile installed on my phone fine. I was prompted to reboot. As soon as it booted back up, I was able to install the latest WatchOS update with no issues.