3 Replies
      Latest reply on Dec 2, 2019 11:52 AM by mrcdeckard
      cdeckard Level 1 Level 1 (0 points)

        Hi, I've modified the AU Filter Demo to accept MIDI notes to control a parameter.  I changed the type to aumf.  It validates and loads into logic pro x 10.4 just fine.

         

        However, when I create a software instrument and go to insert my midi controlled effect in the input slot, it doesn't show up.  I also notice that there aren't any other midi controlled effects in the plugin manager, so I don't have a reference case.

         

        Am I instantiating the audio unit correctly in logic pro (I couldn't find anything in the help docs for logic)?  Is there something else I need to configure or set in the audio unit so that logic "sees" it correctly?

         

        Thanks!

        Chris

        • Re: aumf in logic pro x (10.4)
          cdeckard Level 1 Level 1 (0 points)

          Anyone?  I tried this in AUlab as well with similar behavior (inserts just fine as audio effect, but not as an input to an instrument track).

           

          If I change the audio unit type to an instrument, I can confirm that my MIDI handler is getting called (via NSLog()).  Of course, it doesn't process audio.

           

          Should I file a bug report?

           

          Thanks!

          Chris Deckard

            • Re: aumf in logic pro x (10.4)
              HN - Paris Level 1 Level 1 (0 points)

              I try also to use MIDI and audio inside a AudioUnit v3.

              The doc says that only 'aumu' and 'aufx' are available, I tried 'aumf' but without success for instance. The validation of a 'aumu' in Logic works, but the plug does not produce any sound.

              In the case of IAA, I did a synth wich uses the microphone (the vocoder VoxUnit). It works fine, but the audio input was the microphone of the iPad . I'd like something like a MIDI effect for AU3.

               

              I hope that AU3 will authorize MIDI and Audio Input soon.

            • Re: aumf in logic pro x (10.4)
              mrcdeckard Level 1 Level 1 (0 points)

              I'm checking in on this some months later (Nov 2019), and it still seems Logic won't instantiate v3 aumf audio units. 

               

              Any info would be appreciated.