3 Replies
      Latest reply on Dec 6, 2017 6:05 AM by velo
      Gil Level 1 Level 1 (0 points)

        Hello,

         

        I have an ARKit game (Imagipets AR) currently on the store. Worked fine on iOS 11.1.2, however after upgrading to iOS 11.2 the animations of the dragons don't work anymore.

        Can't launch the debugger yet as i'm still downloading xcode 9.2 beta (any final version coming?) but is anyone else experiencing scenekit animations issues with iOS 11.2?

         

        Thanks

        • Re: Scenekit animations stopped working on iOS 11.2
          Gil Level 1 Level 1 (0 points)

          btw, i use an animationPlayer with scnAnim files:

           

          if player == nil {
                      if let url = Bundle.main.url(forResource: "art.scnassets/animations/\(name)", withExtension: "scnanim") {
                          let anim = SCNAnimation(contentsOf: url)
                          player = SCNAnimationPlayer(animation: anim)
                      }
                  }
          skeleton.addAnimationPlayer(player!, forKey: name)
          player?.play()
          
            • Re: Scenekit animations stopped working on iOS 11.2
              Gil Level 1 Level 1 (0 points)

              I think the issue is with SCNAnimationEvents

               

              I use SCNAnimationEvents to chain animations.

              I start the event a little before the end of the previous to allow blending the animations.

               

              For some reasons i can't understand yet, sometimes the animation events are not triggered although it worked fine on previous iOS versions.

               

              Anyone else has issues with SCNAnimationEvents not triggered in iOS 11.2?

            • Re: Scenekit animations stopped working on iOS 11.2
              velo Level 1 Level 1 (0 points)

              I have a similar issue reading PDF file from Main Bundle. File exists there, but it cannot be presented to te user. I use QuickLook framework. And yes, all was working fine before iOS 11.2
              Here is the part of code:

               

              func previewController(_ controller: QLPreviewController, previewItemAt index:Int) -> QLPreviewItem {
              
                 let path = Bundle.main.url(forResource: episode, withExtension: "pdf")
                 let url = NSURL.fileURL(withPath: (path?.path)!)
                 return url as QLPreviewItem
              }
              
              override func viewDidLoad() {
                 ...
                 let viewPDF = QLPreviewController()
                 present(viewPDF, animated:false, completion:nil)
              }
              

               

              The error I am getting after update on 11.2 is:

              Couldn't issue file extension for url: file///var/containers/Bundle/Application/BD468...../NameOfApp.app/File001.pdf #PreviewItem

               

              If I copy all the PDF files (around 200Mb) from Main Bundle to Documents Folder and change path, it works fine.

               

              let path = FileManager.default.urls(for: .documentsDirectory, in: .userDomainMask).first?.appendingPathComponent(episode+".pdf")
              

               

              But the problem is that now I have double size of PDFs (400 Mb), since I can't move or remove files from Main Bundle.

              Any idea?