1 Reply
      Latest reply on Jan 1, 2018 1:39 PM by Faizatron101
      aleclarson Level 1 Level 1 (0 points)

        Please post your answer on StackOverflow: https://stackoverflow.com/questions/46939564/cannot-connect-to-any-https-url-on-ios-11-simulator

         

        Using Xcode 9.0.1 and iOS 11.0.1, going to https://google.com results in "This Connection Is Not Private".

         

        Apparently, the server certificate is not being trusted by the simulator.

         

        How can I get around this problem?

         

        I've tried:

        - Restarting the simulator

        - Restarting my MacBook

        - Selecting "Hardware > Reset All Content and Settings" in the simulator

         

        I've tried many HTTPS urls without success.

        • Re: HTTPS on iOS 11 simulator not working
          Faizatron101 Level 1 Level 1 (0 points)

          The anti-virus on your computer could be causing this issue. The web shield scanning for unsecured or private connections is not letting the WebKit or SafariViews to load any urls.

          If your computer is running Avast:

               Try unchecking the "Scan for secured connections" in the preference tab / shields tab / settings link at Web Shield row

          Hope that helps!