4 Replies
      Latest reply on Jan 8, 2019 2:02 AM by eskimo
      dgbarreto Level 1 Level 1 (0 points)

        Hi everyone!

         

        I`m having an odd problem with localization. I localized my app to English and Brazilian Portuguese. They both work fine, except for the launch screen.

        It ignores completely my localization in Pt-Br. I have just a label on it with a loading message. I've tried both strings and storyboards files with no use. Only the english is loaded.

         

        Do you guys have any idea why this is happening?

         

        Thanks!

        Danilo

        • Re: Launchscreen ignoring my localization
          KMT Level 9 Level 9 (14,185 points)

          The proper/easiest way to localize a launch image is to embed that text into the image. Saves headscratching...

          • Re: Launchscreen ignoring my localization
            QuinceyMorris Level 8 Level 8 (5,980 points)

            From the HIG:

             

            https://developer.apple.com/ios/human-interface-guidelines/graphics/launch-screen/

             

            "Avoid including text on your launch screen. Because launch screens are static, any displayed text won’t be localized."

             

            iOS apps are not supposed to display a "loading message", and they are not expected to display any text at all in the launch storyboard.

              • Re: Launchscreen ignoring my localization
                Claude31 Level 8 Level 8 (5,785 points)

                I face the same problem now. Development language is french, but launch screen displays always in english.

                 

                So, I understand we should not use text. But then, what is the purpose of launchScreen.strings, which are created for every language ?

                 

                It seems to read the text always from launchScreen.strings(English), whatever settings for the language on iPhone. Why english ?

                  • Re: Launchscreen ignoring my localization
                    eskimo Apple Staff Apple Staff (11,355 points)

                    I’m not 100% sure what’s going on here but I suspect that file is getting created because you’ve localised your LaunchScreen.storyboard file.  That file should not be localised.

                    Try this:

                    1. Create a new iOS project from the Single View App template.

                    2. In the project editor, add a localisation.

                    3. As this in the first localisation (other than the the base), Xcode will ask you which files you want to localise.  It does this by showing you a list of localisable files, where all files start out as checked.  You’ll want to uncheck LaunchScreen.storyboard.

                    You could reasonable argue that showing you LaunchScreen.storyboard here is a bug (or perhaps it should be unchecked by default), and if so I recommend you file a bug report about that.  Please post your bug number, just for the record.

                    Share and Enjoy

                    Quinn “The Eskimo!”
                    Apple Developer Relations, Developer Technical Support, Core OS/Hardware
                    let myEmail = "eskimo" + "1" + "@apple.com"