1 Reply
      Latest reply on Aug 4, 2017 3:28 PM by Claude31
      Claude31 Level 8 Level 8 (5,775 points)

        This is an IOS App developed with XCode 8.3.3. Built for target 9.3.


        I have a func that is called to play a different beep, depending I swipe on right or left. But that's not the point.


            func playInputClick(direction forward: Bool) {
                var filePath: String?
                if forward {
                    filePath = Bundle.main.path(forResource: "ButtonTap", ofType: "wav")
                } else {
                    filePath = Bundle.main.path(forResource: "SecondBeep", ofType: "wav")
                   let fileURL = URL(fileURLWithPath: filePath!)
                    var soundID:SystemSoundID = 0
                    AudioServicesCreateSystemSoundID(fileURL as CFURL, &soundID)


        When I download then run the App on iPhone 5C, IOS 10.2.1, works OK, the beeps are audible when swiping.


        But on an iPad Mini, IOS 9.3.5, no sound at all.

        I've check I get sound by testing in susyem preferences and ajusting some sounds.


        What could be the reason ?

        • Re: wav sound does not play on iPad 9.3.5 but plays on iPhone5
          Claude31 Level 8 Level 8 (5,775 points)

          As a precision:

          I checked do not Disturb is Off

          works as well on iPad Air, IOS 10.3

          It worked in the past on iPhone5C and iPad Air both runnung IOS 8.2.

          Cannot remember how it worked on iPad Mini qith IOS 8.


          I read on this forum

          h ttps://discussions.apple.com/thread/7655893?start=0&tstart=0

          about issuez with sound on IOS 9.3.5


          Was that confirmed ?

          Problem is iPad Mini cannot be upgraded beyond 9.3.5


          Found a solution here :

          h ttp://appletoolbox.com/2012/08/no-sound-after-ios-update-on-iphone-ipad-or-ipod-touch/

          • For iPad, tap Settings > General and change the Lock Switch function from Rotate to Mute. Then, using the side switch, turn mute off and then on again.