10 Replies
      Latest reply on Dec 2, 2017 7:11 AM by iQQator
      sixcolors Level 1 Level 1 (10 points)

        After installing on a 2010 Mac Pro the boot disk did not convert to APFS.

         

        Rebooted to restore partition and ran disk utility. Converted to APFS.

         

        Converson worked.

         

        Rebooted back and it booted to restore.

         

        Chose macOS High Sierra APFS for startup device. It said that it could not bless for startup.

         

        Rebooted to macOS Serirra drive and chose macOS High Sierra as startup.

         

        Booted back to restore.

         

        Appears to be an issue with booting from 2010 Mac Pro to APFS drives or something went wrond with this conversion.

         

        I am using a 2.5" OCZ SSD sitting in the lower optical bay for the beta macOS. 3rd party TRIM enabled.

         

        Is APFS boot on 2010 Mac Pro unsupported or is this a bug?

        • Re: APFS no boot 2010 Mac Pro
          Dr_AL Level 1 Level 1 (0 points)

          believe the release notes say that it is not supported on the Mac Pro in this release.

          • Re: APFS no boot 2010 Mac Pro
            Bluishoul Level 1 Level 1 (0 points)

            Got the same problem, but even worse: I can just see a 'Folder with A Question Mark' after reboot

             

            Now I am trying to recover from internet

            • Re: APFS no boot 2010 Mac Pro
              lowercaseman Level 1 Level 1 (0 points)

              I ran into the exact same issue. I'm just gonna go with this for now and await an update for converting with later release.

              • Re: APFS no boot 2010 Mac Pro
                Kurt Lang Level 1 Level 1 (0 points)

                Same here. I updated my Sierra partition to the High Sierra beta last week. Saw that it was still HFS+ and looked around to see why it wasn't APFS. The common answer that popped up was that you were supposed to check a box at the installer splash screen to do that as you installed High Sierra. I wondered if I missed seeing it. More on that in a bit.

                 

                The next thing I found was that for those users who were "in a hurry" and missed the check box, you could boot to recovery mode and update the drive/partition to APFS after the fact. Okay, I must have missed it, though I didn't remember seeing such a check box. So to recovery mode I went and updated the High Sierra partition to APFS. Disk Utility made no mention of any errors. Just a bunch of messages noting each step, and a happy green check mark for Done!

                 

                All seemed good except the High Sierra partition would not appear anywhere in El Capitan or older versions of the Mac OS I can boot to. Not even Disk Utility in El Capitan would show High Sierra in the list of available drives. It would if I clicked the option to partition the drive it was on, but it would only show the High Sierra partition as unknown. Not that it was a great surprise to see El Capitan didn't know what APFS was.

                 

                Like sixcolors, booting back the recovery mode and trying to select High Sierra as the startup disk (recovery being the only place the partition would even appear in a list), it was marked as unable to boot because it had not been blessed.

                 

                Since High Sierra was now a completely dead partition, I had to boot to another drive with El Capitan on it, completely wipe my SSD and restore the Sierra and El Capitan versions back to the way they were.

                 

                The real test to myself then was upgraded Sierra to High Sierra again. No, I hadn't missed any check box to update the drive to APFS. There isn't one there at all.

                 

                So, a 2010 Mac Pro is supported for High Sierra, but not APFS? I presume such bottom of the supported list models are going to require a firmware update in order to boot APFS. Or, we may not get that option at all and such older Macs will have to remain on HFS+ for High Sierra.

                  • Re: APFS no boot 2010 Mac Pro
                    Crudgle Level 1 Level 1 (0 points)

                    Added after more research: It has been reported that the Public Beta 2 release notes warn: "Unsupported configurations in this seed release: HDD-only Macs cannot be converted to APFS."

                     

                    Well, [expleteive deleted] why can't Public Beta testers see the release notes ?  I tried and got a permission error on my non-paid developer account.  How many years of life have people around the world lost because they couldn't access that little bit of info.

                     

                     

                     

                     

                    I've had much the same experience with my late 2009 27" iMac.  There was no option to upgrade to APFS during the install.  I also tried to upgrade via the Recovery partition and ended up losing the ability to boot from the 10.13 drive.  It also un-paired my Mighy Mouse but I guess that's just the usual beta glitch.

                     

                    I'm installing on an external Firewire drive which before your report, I thought was the problem.  Now, I'm thinking Apple have left something out of the installer or the documentation.

                     

                    It's very odd as I have already been able to test APFS on that same Firewire drive while running 10.12.4.  So, I don't understand why it's not possible now.

                     

                    I'm hoping that more people will report this both in feedback to Apple and in discussions.  I put up this post before noticing yours: https://forums.developer.apple.com/thread/82592.

                     

                    Cheers.

                      • Re: APFS no boot 2010 Mac Pro
                        Kurt Lang Level 1 Level 1 (0 points)

                        Same here. What release notes? I looked most every logical place I could think of to find them, starting here on the developer site. Search terms you'd think would turn up something get blank results. Like, "high sierra release note", or "10.13 release note". Nothing.

                         

                        The drive I upgraded is an SSD, and I still didn't get an option to convert it to APFS on the fly. Doing it after, as noted above, ended in a non-bootable partition that couldn't be seen from any previous OS version. I submitted a bug report for this failed APFS conversion earlier today.

                         

                        Excellent notes I think on your other topic.

                         

                        Here's something weird. Installing High Sierra removes the previous recovery partition. The new one is actually a hidden image within the High Sierra partition. Or something like that. I read in another post here it's no longer a separate partition. Anyway, I couldn't boot to High Sierra after trying to make is APFS, and holding Command+R on a startup or restart would just toss me to my El Capitan partition as the next bootable drive found. But, I could still do an Option key start (Startup Manager) and select the High Sierra recovery drive even though High Sierra itself was dead.

                         

                        I'm back to High Sierra as an HFS+ partition now so I can at least start testing my apps on it. I sure would like to see it operating as APFS, though. One thing I noticed right away with HS is that deleting files is strangely slow. Things you put in the trash just kind of hold their position on screen for a few seconds, then suddenly disappear. But this is beta, of course, and there's a lot of debugging code in the OS at the moment.

                    • Re: APFS no boot 2010 Mac Pro
                      LarryJoe33 Level 1 Level 1 (20 points)

                      I have a late 2011 13" MBP with a Crucial MX300 SSD as my boot drive.  I had the checkbox when I tried to install the first public beta.  I got an error message during the install very quickly noted something about being unbable to update the file system.  Unfortunately, when I restarted, the option was gone and I was caught in a loop of failures trying to update the file system.  I also could not find a way to boot back to Sierra.  It was caught in a loop of restarts and atemtpitng to upgrade to APFS as part of the install.  Again, check box was gone.

                       

                      I thought for sure my prior Sierra build was still there in tact.  It looked like it.  Unfortunately, I gave up and retored a CCC image to the SDD and then I tried to install public #1 again and this time I didn't check the box.  It installed fine.  I then went into recovery mode and tried to upgrade the SSD to APFS via disk utility.  I selected it and I get a 6953 error.

                       

                      I wonder if my MBP is too old??  Could it be the thrid party drive?  The firmware of the drive?  I have not upgraded the firmware of the drive.  It's a pain with a Mac.  Crucial has a utility for Windows but not for Mac. I honestly don't think its the firmware either.

                       

                      I am dying to play with APFS.  It's really the only thing about High Sierra that is substantively different from Sierra.  I am hoping the next build resolves this.  I have seen similar issues with other testers on similar machines.  Keep us posted.

                      • Re: APFS no boot 2010 Mac Pro
                        iQQator Level 1 Level 1 (0 points)

                        APFS has stuck on 13" Macbook pro mid 2010 and won't load release 10.13