62 Replies
      Latest reply on Nov 8, 2017 6:42 AM by siddharth3322
      mgarcia Level 1 Level 1 (0 points)

        Hello,

         

        I am currently in the process of uploading hosted content IAP pkg files via Application Loader.

        I log-in, then press "New In-App Purchases". From here, I see the list of my registered iTunes Connect apps.

        I select the app that has the IAPs waiting for upload, then press "Manage".

         

        An error is displayed: "There was a problem retrieving the metadata", followed by "No suitable application records were found. Verify your bundle identifier 'XXX' is correct.". If I try the same with the other apps, I get the exact same error. I was able to upload an IAP few weeks ago and it worked perfectly.

        I wonder how it can check for the bundle identifier since I'm not even able to upload my pkg file. The app is not currently available on the App Store (only via TestFlight), but I have no issue upload new builds regularly.

         

        I double checked everything on my App ID, certificates, in-app purchases metadata and everything is OK.

        Is there a known issue with the Application Loader right now ? I couldn't find any relevant information.

         

        Thank you in advance for your help.

        Mathieu.