0 Replies
      Latest reply on Dec 1, 2016 11:41 AM by MendelK
      MendelK Level 2 Level 2 (90 points)

        Hi!


        After making two minor modifications to the development scheme on the CloudKit dashboard, I tried to deploy these changest to production.

         

        Sadly, an "Unexpected Error" occurred and deployment is now stuck. Everytime I open the CloudKit dashboard, I am greeted with an error "Unexpected Error" message. The logs to this error indicate that the dashboard seems to fail to query some kind of status from deployment and gets a http status code 502:

         

        Thu, 01 Dec 2016 19:16:46 GMT: INFO: --> Request 12: GET to https://p29-ckdashboardws.icloud.apple.com/r/v3/user/iCloud.com.syniumsoftware.macfamilytree8/production/publicDB/admin/deployment/status/id/be886b90-b7f9-11e6-82f9-008cfac10ec4?request_uuid=586cb2b9-43db-4839-979b-4aafe13a55a3&team_id=LWL9XTYF8Q, headers: Content-Type=text/plain, body: (empty)

        <-- Response 12: 502 (24267ms), headers: Cache-Control=no-cache, no-store, private, Content-Type=application/json; charset=UTF-8, X-Apple-Request-

         

        Re-deploying the development schema to production results in the same "Unexpected Error". The only thing that might give a clue to what's happing are these lines from the error log right after deployment fails:

         

        Thu, 01 Dec 2016 19:02:41 GMT: DEBUG: Dashboard.RecordTypeModel({createTime: 1473255376371 , etag: issy7nqy , modifyTime: 1474632670670 , name: BookDiagramReportGeneratorSection , definitionId: b1b48380-b157-4c92-b978-de1bda399d1c , permissions: [object Object],[object Object],[object Object],[object Object] , fields: [object Object],[object Object],[object Object],[object Object],[object Object] , metaFields: [object Object],[object Object],[object Object],[object Object],[object Object],[object Object] , systemFields: , privateRecordCountFromCloudKit: 0}) READY_CLEAN

        Thu, 01 Dec 2016 19:02:41 GMT: WARN: Merge conflict for storeKey 145 (RecordType) during commit: UPDATE


        I've tried so far resetting the dev enviroment from production, making a slight change and redeploying...nothing helped.


        I've created a bug report #29460043


        Has anyone any idea what could be wrong?