1 Reply
      Latest reply on Aug 11, 2016 6:23 PM by waterdoggie
      AnnArborMark Level 1 Level 1 (0 points)

        Has anyone been successful in using Xcode 8 beta 5 to build and run a watchOS 3 app on an Apple Watch? I always get "Preparing to Install <appname> WatchKit App.app..." forever. I believe it was working around Xcode beta 3 but definitely not in beta 4 or 5.

         

        From Xcode beta 5 release notes:

         

        • Build and run may not launch or attach to the app on Watch. Workaround: Change the watch face. (27019191)

        I tried this voodoo with no luck.

        • Re: Preparing to Install WatchKit App
          waterdoggie Level 2 Level 2 (55 points)

          Changing the watch face has never worked for me, but I have seen putting the watch on the charger trigger it to attach.

           

          Worst case, you can quit XCode, disconnect phone, reboot watch and phone, open XCode, reconnect phone, then deploy usually starts working.

          1 of 1 people found this helpful