2 Replies
      Latest reply on Aug 4, 2016 2:39 PM by timgcarlson
      timgcarlson Level 1 Level 1 (0 points)

        I'm having some difficulty getting Universal Links to work correctly, and am not sure what I'm doing wrong. I followed the docs on setting everything up...

         

        1. Added the URL to the app's cababilities (Associated Domains)

        2. Uploaded the unsigned plain text file (with MIME type application/json) to my server http://my.cozi.com/apple-app-site-association.

         

        3. Added a dictionary for both the Team ID and App ID to the apple-app-site-association file, becuase I wasn't sure which one to use (niether worked).

         

        4. Validating the url with the App Search API Validation Tool gives "Error no apps associated with url"

        The behavior that I'm getting now is it will show the "Open in..." alert briefly, but will close on it's own and just open the URL. This was the same behavior before I tried supporting Universal Links. An example link I'm trying is http://my.cozi.com/addtocozi/?content=http%3A%2F%2Fmy.cozi.com%2Ftest%2Faddtocozi%2FsampleCalV3.json&type=calendarV3

         

        Any suggestions on what I'm doing wrong here, or missing, would be much appreciated! Can I even test this before there's a version on the App Store with "applinks:my.cozi.com" in the Associated Domains?

         

        My apple-app-site-association file looks like the following.

        • Re: Cannot get Universal Links working for my app and domain
          pdm Apple Staff Apple Staff (1,770 points)

          Yes, you can test this without the app being in the store, although I think the validation tool will report this error since it doesn't know anything about this app. 

           

          At a glance, things do seem in order and I don't see anything out of sorts.  What OS are you testing this with? 

           

          Also, where are you testing opening this URL?  I'd recommend using Mail or Notes, since the handling of universal links in Safari can be a little confusing (the rules of when to open Universal Links sometimes trip people up.  What I like to do is use Mail, tap-hold on a link to get the sheet of action buttons and then see if "Open in [app]" is in there.  If it is then your Universal Links configuration is valid.  If it's not, then the device is not recognizing your setup.