1 Reply
      Latest reply on Dec 22, 2018 4:32 AM by Ardshinbank
      EtherDev Level 1 Level 1 (0 points)

        I get the following error message whenever I try to build to an actual device (works fine when using the simulator, and I can build to and install via TestFlight without issue):

        Unable to install "AppName"

        The certificate used to sign "AppName" has either expired or has been revoked. An updated certificate is required to sign and install the application.


        Everything was working fine, then this error started appearing for seemingly no reason. I have tried the following fixes (multiple times, and in varying orders), but nothing has worked:

        • Restart Mac
        • Restart Xcode
        • Re-install Xcode
        • Re-install certificates & provisioning profiles (overwriting old ones, and completely deleting old ones)
        • Delete & Revoke old certificates & re-create and install them
        • Preferences -> Accounts -> View Details -> Download All
        • Removed all expired certificates & replaced with updated versions
        • Deleted all files related to app development, then cloned fresh from git


        I've tried building & running the app on a different Mac and it works fine, so it's definitely something wrong with my machine but I have no idea what.


        Originally asked on StackOverflow.