3 Replies
      Latest reply on Dec 3, 2015 7:22 AM by neal1
      KHawkerNEE Level 1 Level 1 (0 points)

        There appears to be a bug with checking out a project from SVN in xcode 7.

         

        Source Control -> Check Out

        Enter a location that exists like: "svn://example-server/SomeProject".

        It appears to validate that the location exists. The file explorer window pops up to have us select the location to check out to.

        After selecting the Download button, a pop up appears that states: "The source control operation failed because the location "svn://example-server/SomeProjec" could not be found."

         

        Notice the missing "t" at the end of the URL. No matter what location I enter this pop up shows the last character missing.

         

        I've even tried dubilicating the last character as a work around, but the location then fails the initial validation before you select the save location.

         

        Additionally, in xcode versions <5 you would get a file explorer for the repository location you enter, so you could select a specific folder. That seemed to went away in Xcode 5 & 6, but there was a way to get that browser by adding a slash "/" at the end of the URL. In Xcode 7, that seems to have gone away as well.

         

        Xcode 7 is currently unusable for our company since we can't check out any projects from SVN.

         

        Does anyone know any work arounds for these issues? We've reverted back to Xcode 6 in the meantime.

        • Re: Xcode 7 SVN not working
          rshuston Level 1 Level 1 (10 points)

          I haven't tried doing a new checkout, but in my SVN working directory that I was happily managing with Xcode 6.4, after upgrading to Xcode 7 and then to El Capitan, I can no longer view the modified files in the project history window. Each time I select the "Show N modified file(s)" button, the differencing window opens but then, after selecting a particular file, I get a "The source control operation failed because no working copy could be found" error alert panel. Git operations also seem broken on some of my Git working copies (not all of them, but most of them). The problem is also in Xcode 7.1 beta 3. I don't know whether it was the El Capitan upgrade that screwed things up, but I have two machines that exhibit the same behavior.

           

          I've filed a bug report but I haven't seen any review activity on it yet. It's very exasperating why each "upgrade" seems to keep breaking fundamental things that weren't broken beforehand.

            • Re: Xcode 7 SVN not working
              neal1 Level 1 Level 1 (10 points)

              Same here. It appears that SVN support on Xcode 7.0 and 7.1 is broken. Right now I have to use xcode 6.4 for doing branch merges as well as checking file history. This is going to be a big problem for me soon, because I'm getting a new mac with El Capitan and Xcode 6.4 won't run on it*.

               

              --Neal

               

              *Edit: Xcode 6.4 can still be used for source control on El Capitan.

              • Re: Xcode 7 SVN not working
                neal1 Level 1 Level 1 (10 points)

                Bug # 23742220 filed for broken modified history viewing bug.