6 Replies
      Latest reply on May 15, 2018 12:00 AM by iQser_Developer
      MrMikeT Level 1 Level 1 (0 points)

        ""I have an app that includes InApp purchases.

         

        I'm following the guidelines at:

         

        https://developer.apple.com/library/ios/documentation/NetworkingInternet/Conceptual/StoreKitGuide/Chapters/ShowUI.html#//apple_ref/doc/uid/TP40008267-CH3-SW11

         

        "On a development iOS device, sign out of the App Store in Settings. Then build and run your app from Xcode."

         

        "Use your app to make an in-app purchase. When prompted to sign in to the App Store, use your test account. Note that the text “[Environment: Sandbox]” appears as part of the prompt, indicating that you’re connected to the test environment."

         

        I have signed out the App Store in the Settings app on this device.  Then I run my new app from Xcode and attempt to make an InApp purchase.  The pop-up I get is titled "Apple ID Password" without any mention of [Environment: Sandbox]...  I have tried this on two different devices, and still don't see the sandbox text.

         

        Any idea what I could be doing wrong?

         

        We have tested and released the app several times before, and I remember the sandbox text appeared in the past...  Not sure what I'm missing here.

         

        (We even tried using one of our test users to sign-in without the sandbox text, but that didn't work.  Guess it's bricked that account so we'll need to create another test user...) 

         

        Thanks for suggestions

        Mike