3 Replies
      Latest reply on Aug 16, 2015 3:11 PM by Max108
      donmontalvo Level 1 Level 1 (0 points)

        I've been testing El Capitan Beta 6 on a MacBook Air and I found one issue that I hope someone can confirm is a bug, or maybe I'm just doing something wrong.

         

        Starting with a USB bootable El Capitan Beta installer, initialize the SSD target drive, then install El Capitan, then go through the tedious/painful process of having 10+ GBs of updates pulled down (just a guess), until we are at El Capitan Beta 6.

         

        Right off the bat I notice Recoverey HD is missing.

         

        Running diskutil list shows Macintosh HD is there, but not Recovery HD.

         

        Running diskutil cs list returns  No CoreStorage logical volume groups found.

         

        I booted off the USB bootable El Capitan Beta installer and created a DMG using both New image from Macintosh HD and New image from folder... this way I can at least restore Macintosh HD at a later date if necessary (fully updated to Beta 6).

         

        I didn't bother to create an image from the SSD, since it is missing Recovery HD. Ideally I should be able to, to capture both Macintosh HD and Recovery HD.

         

        I'll probably get slapped for asking, but I'd like to avoid going through this exercise a third time...

         

        Is there a way to create a proper Recovery HD in El Capitan Beta 6 where it does not exist?

         

        I'll be in purgatory if anyone responds.

         

        TIA,

        Don

        • Re: Recovery HD missing (El Capitan Beta 6)
          Max108 Level 8 Level 8 (5,800 points)

          Hi Don,

           

          You're right, the official process does require a reinstall - I'm hopeful that the next update will be a combo though, which you're probably aware would mean you'd only need to reinstall 10.11 Beta 1 from the USB drive and then update straight to Beta 7 - it's likely that we'll only have to wait 2 days to see...

           

          Anyway, the process to manually create the RecoveryHD partition requires you download the El Capitan Installer again (if it isn't still sitting in your Applications folder from before) - 2nd time around normally requires you to hold alt/option while you click the Purchases tab...

           

          Happily, from there there's a script that cuts out all the intricate stuff, which can be downloaded from here: https://dl.dropboxusercontent.com/u/13872235/Musings/Recovery%20Partition%20Creator%203.8.zip

           

          Max.

            • Re: Recovery HD missing (El Capitan Beta 6)
              donmontalvo Level 1 Level 1 (0 points)

              @Max108 thanks for your response. I'm one of those techs who saves everything as he works, so I have the latest El Capitan Beta installer app.

               

              I downloaded the El Capitan Beta Installer app to /Applications on the MacBook Air test machine.

               

              Then I downloaded the AppleScript app and ran it, and I skipped past the error:

               

              You are not running a compatible version of OS X

               

              I hit OK and selected the target disk Macintosh HD > OK. The next dialog box I got is:

               

              We will now check your drive for errors. You can skip this but it is not recommended

               

              I hit OK and gave it less than a minute (because SSD), then got:

               

              We are about to start the recovery creation process. Click OK to continue and choose the OS version you are going to install when prompted.

               

              I hit OK and after a few seconds I got this dialog:

               

              Choose OS Installer Version [10.7 or 10.8] [10.9]

               

              Since we are installing 10.11, I took a chance and chose 10.9. Got Creating Recovery artition. This is going to take a bit. with an Abort Recovery Partition button that for obvious reasons I did not hit.

               

              About a minute later I got a Your recovery partition has successfully been created. Reboot and hold the command and r keys to boot to the recovery partition. I hit OK and then quickly ran diskutil list to confirm Recovery HD is there (yay!). I ran diskutil cs list and got the same No CoreStorage logical volume groups found which I sort of expected.


              I rebooted holding COMMAND-R and gave it a couple seconds to boot. BAM! There we go, El Capitan Beta recovery partition!

               

              This is awesome, hopefully this thread with all the details will help the next person who has this problem.

               

              PS, do we know who the developer of the AppleScript app is? I'd like to provide some helpful feedback, and ether-beer if possible.

               

              Thanks,

              Don

                • Re: Recovery HD missing (El Capitan Beta 6)
                  Max108 Level 8 Level 8 (5,800 points)

                  Glad it worked - I did it manually once with Mavericks (pkgutil was heavily involved I remember) and knew that this script worked with Yosemite, so I was pretty sure that the same process would be continuing to hold for subsequent versions of OS X - good to have it confirmed though. I had the sense from reading your question that you'd appreciate the context of the warnings the script gave (I ran it just shy of the final step myself) and push on anyway, but the step-by-step you posted will be very reassuring to many others - thanks.

                   

                  Who wrote the AppleScript?  This guy: http://musings.silvertooth.us/about-me/