0 Replies
      Latest reply on May 13, 2020 2:41 PM by vikt0r40
      vikt0r40 Level 1 Level 1 (0 points)

        Hello,

         

        I am facing the following issue:

         

        I have a custom framework (iOS) which has dependancy of another 3 frameworks. The framework is written in Objective C. While developing with no problems at all, I recently recieved build errors:

         

         

        Declaration of 'jmp_buf' must be imported from module 'Darwin.C.setjmp' before it is required
        Could not build module CoreFoundation
        Could not build module Foundation
        Could not build module UIKit
        Could not build module CoreGraphics
        
        

        I haven't change any system files or files from some system framework. Interesting is that If I install the framework on separate mac with the same xcode I get build success. After a while I get these errors again.

         

        Screenshot-2020-05-12-at-10-29-42 — ImgBB

        I am also attaching a screenshot.

         

        I already tried cleaning derived data, clean build, clean build folder.. I even re-install Xcode and still the same

         

        Sometimes on real device is bulding with success on simulator not, but most of the time on both places is with this error.

         

        Xcode version: 11.4.1

        macOS Catalina version: 10.15.4

        Real device tested: iPhone XS 13.4.1

        Simulator tested: iPhone 11 13.4.1 and iPhone X 12.4