5 Replies
      Latest reply on May 26, 2020 6:00 AM by Dblake
      Dinesh1129 Level 1 Level 1 (0 points)

        We have two targets.

         

        MCOM and MCOM QA and both are built using iOS 12 SDK.

         

        But when we submit the MCOM build to Test Flight, we get following message.

         

        We identified one or more issues with a recent delivery for your app, "Macy's" 8.4.2 (8042.200501.150315). Your delivery was successful, but you may wish to correct the following issues in your next delivery:

        ITMS-90725: SDK Version Issue - This app update was built with the iOS 12.4 SDK. As of June 30, 2020, updates to apps for iPhone or iPad must be built with the iOS 13 SDK or later.

         

        But when we try to upload MCOM QA build to Test Flight, we get different message

         

        ERROR ITMS-90725: "SDK Version Issue. This app was built with the iOS 12.4 SDK. New apps for iPhone or iPad must be built with the iOS 13 SDK or later." Return status of iTunes Transporter was 1: ERROR ITMS-90725: "SDK Version Issue. This app was built with the iOS 12.4 SDK. New apps for iPhone or iPad must be built with the iOS 13 SDK or later."

         

        So basically Test Flights assumes our QA apps as new app but release apps as update.

         

        Does anyone faced this issue and how to resolve this?