8 Replies
      Latest reply on May 28, 2020 4:08 PM by davemaj
      Balaji Ramakrishnan Level 1 Level 1 (0 points)

        Hi iOS devs,

         

        I'm developing Social networking app which includes APNS for Push notification and VoIP for Voice calls. After migrated to Xcode 11.3 and in iOS 13+ devices, sometimes the device token callback not called properly.

         

        func application(_ application: UIApplication, didRegisterForRemoteNotificationsWithDeviceToken deviceToken: Data) {
        // APNS Token callback
        }

         

        func pushRegistry(_ registry: PKPushRegistry, didUpdate pushCredentials: PKPushCredentials, for type: PKPushType) {
        // VOIP Token callback
        }

         

        I tried killing the app and restarting, won't help. After some different ways, i tried turning off & on network and opened my app and then above two callbacks working for me.

         

        Also, I searched about this issue and most of developers suggesting to Restart device or turn off & on data/wifi.

         

        I don't think this could be possible solution and it's not consistently occuring in a same device. It's occuring randomly in different iOS 13+ devices mostly on fresh installation.

         

        Please suggest your solutions.


        Thanks in Advance,

        Balaji.