0 Replies
      Latest reply on Feb 25, 2020 8:54 AM by dagsmans
      dagsmans Level 1 Level 1 (0 points)

        We have an app with background fetch capability. It was working fine with preferred execution interval of 10 minutes.

        At some point in time, without any changes to relevant code, this capability seems to stop working for majority of test devices.

         

         

        We can trigger this method with Xcode tools, but without debug "performFetchWithCompletionHandler" is just never called (not once in days).  But some test devices are still getting calls to this method as expected, without any debug interruptions.

         

         

        We already tried setting other time intervals  - that did not help. We also tried new iOS 13 background tasks API, but that did not help too.

        We suppose this change happened around the same time we integrated WatchOS companion app. Of course, we tried removing it - but that did not work either.

        Resetting project repo to some past point when backgroundFetch was definitely working - also did not work.

        Completely resetting affected iPhones and watches (reset all content and settings) - did not help.

         

         

        Also, app currently seems to break background fetch for other apps too. We tried running a simple example project with background fetch and it did not receive background time as well (without debug interruption).

         

         

        We did not find any correlation between iOS versions and this issue. iPhone11-iOS13.2.2 is affected, while iPhone11Pro with the same iOS version is working just fine. Updating to latest IOS did not help. Other apps influence is probably not the reason - iPhoneSE-iOS13.3.3 with only stock IOS apps does not fetch too.

         

         

        Can WatchOS apps break background fetch capability for entire iOS/developer account? Is there any tools that can help us to determine why our app/s are not getting background time?