2 Replies
      Latest reply on Feb 14, 2020 9:16 AM by PCBuff
      PCBuff Level 1 Level 1 (0 points)

        I'm trying to notarize a kext that has been working fine and today it is giving me a "Status 2" "Package Invalid" error using the same scripts I have used before.

         

        The Email I receive gives instructions to look at the log files, but of course kext's aren't uploaded from within Xcode Organizer, so I can't press the "Show Status Log" button and I have no idea where any notarize logs might be stored.

         

        I'm building the kext with Xcode 10.0 (10A255) as Xcode 11 simply won't build kext's that work (that is for another post) on Mohave 10.14.6.

         

        I also have applications that are notarized, and that notarization worked just fine from within Xcode 10.

         

        Any clues what might be going on since this has worked fine in the past?

         

        Thank you,

         

        David

        • Re: Notarize Kext showing Status 2 Package Invalid
          eskimo Apple Staff Apple Staff (13,095 points)

          of course kext's aren't uploaded from within Xcode Organizer, so I can't press the "Show Status Log" button and I have no idea where any notarize logs might be stored.

          The --notarization-info subcommand of altool will return info about your notarisation request, including a LogFileURL property.

          Share and Enjoy

          Quinn “The Eskimo!”
          Apple Developer Relations, Developer Technical Support, Core OS/Hardware
          let myEmail = "eskimo" + "1" + "@apple.com"

            • Re: Notarize Kext showing Status 2 Package Invalid
              PCBuff Level 1 Level 1 (0 points)

              Thanks, that helped.  It was a long way to go to figure out what the actual error was, but it is finally solved. Strange that this didn't come up before... It was the secure timestamp issue.  Obviously I didn't know about the URL and having to check the Apple developer site for the actual error message, so once I got that it was easy to fix.  Thanks again for the help!

               

              David