2 Replies
      Latest reply on Feb 19, 2020 12:17 AM by seanWilliams85
      SmallBear Level 1 Level 1 (0 points)

        I updated the lastest system ios 13.3.1 (iPhone 8) yesterday .

        And the problem happened .

        My developer account is free account.

        I try remove use_frameworks! and add use_modular_headers! , but it's all no working to me .

        I can't use frameworks which installed by pod after update the iOS 13.3.1 in iPhone 8.

        How i can fix this ?

        • Re: I can't use frameworks with Cocoapod in iOS 13.3.1
          SmallBear Level 1 Level 1 (0 points)

          All the frameworks SHOW the

          dyld: Library not loaded: [...] Reason: no suitable image found.

          problems

            • Re: I can't use frameworks with Cocoapod in iOS 13.3.1
              seanWilliams85 Level 1 Level 1 (0 points)

              I'm having the same problem. Since updating to iOS 13.3.1 - I cannot open any projects using pods on a real device, which is super frustring as I was about to launch my first app on the app store. Works fine on simulator. Please help!

               

              dyld: Library not loaded: @rpath/Alamofire.framework/Alamofire

                Referenced from: /private/var/containers/Bundle/Application/EFC02A4C-452F-4C38-ADC5-016760D653F8/TEST.app/TEST

                Reason: no suitable image found.  Did find:

                /private/var/containers/Bundle/Application/EFC02A4C-452F-4C38-ADC5-016760D653F8/TEST.app/Frameworks/Alamofire.framework/Alamofire: code signature invalid for '/private/var/containers/Bundle/Application/EFC02A4C-452F-4C38-ADC5-016760D653F8/TEST.app/Frameworks/Alamofire.framework/Alamofire'

               

                /private/var/containers/Bundle/Application/EFC02A4C-452F-4C38-ADC5-016760D653F8/TEST.app/Frameworks/Alamofire.framework/Alamofire: stat() failed with errno=25

                /private/var/containers/Bundle/Application/EFC02A4C-452F-4C38-ADC5-016760D653F8/TEST.app/Frameworks/Alamofire.framework/Alamofire: code signature invalid for '/private/var/containers/Bundle/Application/EFC02A4C-452F-4C38-ADC5-016760D653F8/TEST.app/Frameworks/Alamofire.framework/Alamofire'

               

                /private/var/containers/Bundle/Application/EFC02A4C-452F-4C38-ADC5-016760D653F8/TEST.app/Frameworks/Alamofire.framework/Alamofire: stat() failed with errno=1

                /private/var/containers/Bundle/Application/EFC02A4C-452F-4C38-ADC5-016760D653F8/TEST.app/Frameworks/Alamofire.framework/Alamofire: code signature invalid for '/private/var/containers/Bundle/Application/EFC02A4C-452F-4C38-ADC5-016760D653F8/TEST.app/Frameworks/Alamofire.framework/Alamofire'

               

                /private/var/containers/Bundle/Application/EFC02A4C-452F-4C38-ADC5-016760D653F8/TEST.app/Frameworks/Alamofire.framework/Alamofire: stat() failed with errno=1

              (lldb)