0 Replies
      Latest reply on Feb 6, 2020 2:52 AM by tartempion
      tartempion Level 1 Level 1 (10 points)

        "In macOS 10.15.4, use of deprecated KPIs triggers a notification to the user that the software includes a deprecated API and asks the user to contact the developer for alternatives."

         

        This seems strange and somehow inappropriate to display this kind of notifications in a minor OS release. Even more considering that the SDKs for the "alternatives" have not been properly documented so far.

         

        If Apple knows in which OS release the KPIs will stop working, please communicate this piece of information to the 3rd party developers. That would be more helpful to everyone.

         

        If we could avoid another macOS UX disaster as the ones with SKEL and FDA, this would be welcome.