1 Reply
      Latest reply on Feb 2, 2020 11:06 AM by rossross
      rossross Level 1 Level 1 (0 points)

        I'm wondering if there's a known bug in WatchOS 6.1.1 regarding local notifications triggered from the watch?

         

        I have an app that I developed about two years ago on watchOS 4. It would send local notifications from the watch during background processing. It worked great. The code sat for about two years and I was asked to update it. Since updating, I cannot get local notifications from my watch to work when I distribute builds through TestFlight. When I run the app through Xcode it works (both with the Debug and Release schemes). I saved logs in the watch app that show that the UNUserNotifications.current.add() does not pass an error into its completion handler. I can get local notifications from the handset in TestFlight builds to work and I can mirror those on the watch. But I cannot get local watch notifications to work. Does anyone have any idea why this might be? Is there a known bug? Have local watch notifications changed in a breaking way since watchOS 4?

        • Re: WatchOS 6.1.1 local notification triggered from watch never arrives
          rossross Level 1 Level 1 (0 points)

          I've found my issue. I think it's a new bug in watchOS6. It seems that permissions aren't being properly communicated from the handset to the watch. After giving permission for notifications on the handset, I would check for notification permissions on the watch and get .notDetermined. Strangely, if I downloaded the handset app and quickly gave notification permissions BEFORE the watch app had finished downloading, then it properly received notification permissions. I fixed this by simply requesting notification permissions on both the handset and the watch.