0 Replies
      Latest reply on Jan 21, 2020 4:34 AM by strangerx
      strangerx Level 1 Level 1 (0 points)

        Im trying to build and sign iOS application on a new mac.

         

        Using Automatic signing by provisioning profile I always get same error on a stage of CopySwiftLibs

         

        Error sounds like the topic, but it predicated by severeal calls of

         

        /usr/bin/codesign --force --sign [IDENTITY_UUID] --verbose PATH/TO/Frameworks/libswift[LIB_NAME].dylib

         

        Which were exited with code 1 and messages like

        [IDENTITY_UUID]: no identity found

         

        and then reached the famous

        Apple Development: [IDENTITY NAME]: this identity cannot be used for signing code

         

        But there is an exact same [IDENTITY_UUID] in a keychain so call of

        security find-identity -p codesigning

        returns valid identity

         

        I already tried to fully reinstall all the software including mac os on this mac.

         

        Xcode version is 11.3.1 (11C504)

        macOS version is 10.14.6 (18G103)