2 Replies
      Latest reply on Feb 3, 2020 3:46 AM by Fierce Capital
      lizardon Level 1 Level 1 (0 points)

        I am currently using the free developer account to sign that apps that I am currently developing. My attempts to download my watchkit app to my physical watch are constantly unsuccessful due to the error that states that I have no valid provisioning profile. I have tried a multitude of 'solutions' to no avail. I have also attempted to install the phone app to my iphone before downloading it in the watch app on iphone, that didn't work either.

         

        Everything runs smoothly on the simulator and no errors are showing, the console does not log anything and I am simply told that there is an issue with the provisioning profile. The error log follows as such,

         

         

        Unable to install "App Name"

        Domain: com.apple.dtdevicekit

        Code: -402620395

        --

        App installation failed

        Domain: com.apple.dtdevicekit

        Code: -402620395

        Failure Reason: A valid provisioning profile for this executable was not found.

        User Info: {

            DVTRadarComponentKey = 487927;

            "com.apple.dtdevicekit.stacktrace" = (

          0   DTDeviceKitBase                     0x00000001212ef6e7 DTDKCreateNSError + 109

          1   DTDeviceKitBase                     0x00000001212efde9 DTDK_AMDErrorToNSError + 792

          2   DTDeviceKitBase                     0x000000012132f56a __90-[DTDKMobileDeviceToken installApplicationBundleAtPath:withOptions:andError:withCallback:]_block_invoke + 164

          3   DVTFoundation                       0x0000000108bd2c22 DVTInvokeWithStrongOwnership + 73

          4   DTDeviceKitBase                     0x000000012132f301 -[DTDKMobileDeviceToken installApplicationBundleAtPath:withOptions:andError:withCallback:] + 1589

          5   IDEiOSSupportCore                   0x00000001211b7a25 __118-[DVTiOSDevice(DVTiPhoneApplicationInstallation) processAppInstallSet:appUninstallSet:installOptions:completionBlock:]_block_invoke.352 + 4523

          6   DVTFoundation                       0x0000000108d03e8a __DVT_CALLING_CLIENT_BLOCK__ + 7

          7   DVTFoundation                       0x0000000108d05562 __DVTDispatchAsync_block_invoke + 809

          8   libdispatch.dylib                   0x00007fff6527b583 _dispatch_call_block_and_release + 12

          9   libdispatch.dylib                   0x00007fff6527c50e _dispatch_client_callout + 8

          10  libdispatch.dylib                   0x00007fff65281ace _dispatch_lane_serial_drain + 597

          11  libdispatch.dylib                   0x00007fff65282452 _dispatch_lane_invoke + 363

          12  libdispatch.dylib                   0x00007fff6528ba9e _dispatch_workloop_worker_thread + 598

          13  libsystem_pthread.dylib             0x00007fff654d66fc _pthread_wqthread + 290

          14  libsystem_pthread.dylib             0x00007fff654d5827 start_wqthread + 15

        );

        }

        --

        • Re: A valid provisioning profile for this executable was not found
          zerovoid Level 1 Level 1 (0 points)

          Is the provisioning profile installed on your device? There may be an issue where XCode is not embedding your provisioning profile properly in your build output so that your device is able to install it automatically.

           

          You can check if the provisioning profile is installed by connecting the device to your Mac:

               1. Open the Devices and Simulators window from XCode.

               2. Highlight your device and do a control + click, then go to Show Provisioning Profiles...

               3. If your provisioning profile is not there you can manually add it by clicking on the +

               4. Navigate to the provisioning profile and add it

               5. Build your application again and it should install

          • Re: A valid provisioning profile for this executable was not found
            Fierce Capital Level 1 Level 1 (0 points)

            I'm experienceing the same issue ever since installing Xcode 11.3.1

            Tried all the "workarounds" yet nothing seems to work.