3 Replies
      Latest reply on Jan 10, 2020 2:57 AM by eskimo
      goodcyg Level 1 Level 1 (0 points)

        I type in the terminal: lldb

        $ lldb

        Traceback (most recent call last):

          File "<string>", line 1, in <module>

          File "/Applications/Xcode.app/Contents/SharedFrameworks/LLDB.framework/Resources/Python/lldb/__init__.py", line 98, in <module>

            import six

        ImportError: No module named six

        Traceback (most recent call last):

          File "<string>", line 1, in <module>

        NameError: name 'run_one_line' is not defined

        Traceback (most recent call last):

          File "<string>", line 1, in <module>

        NameError: name 'run_one_line' is not defined

        Traceback (most recent call last):

          File "<string>", line 1, in <module>

        NameError: name 'run_one_line' is not defined

        Traceback (most recent call last):

          File "<string>", line 1, in <module>

        NameError: name 'run_one_line' is not defined

        Traceback (most recent call last):

          File "<string>", line 1, in <module>

        NameError: name 'run_one_line' is not defined

        Traceback (most recent call last):

          File "<string>", line 1, in <module>

        NameError: name 'run_one_line' is not defined

        (lldb) exit

        Traceback (most recent call last):

          File "<string>", line 1, in <module>

         

        $ pip install six

        DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.

        Requirement already satisfied: six in /usr/local/lib/python2.7/site-packages (1.13.0)

         

        I entered in the terminal: lldb reported ImportError: No module named six, and then entered pip install six, but prompted Requirement already satisfied: six in /usr/local/lib/python2.7/site-packages (1.13.0), I should How do you do it? My mac has xcode 11 and python2 installed, python3.help me?

        • Re: lldb error import six
          eskimo Apple Staff Apple Staff (12,735 points)

          Xcode comes with its own version of Python, including a copy of six, for the benefit of LLDB and others.  For Xcode 11.3 this is at /Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.7/lib/python3.7/site-packages/six.py.  I’m not sure why lldb isn’t picking up that version.  What version of macOS are you running?  And what version of Xcode?

          Share and Enjoy

          Quinn “The Eskimo!”
          Apple Developer Relations, Developer Technical Support, Core OS/Hardware
          let myEmail = "eskimo" + "1" + "@apple.com"

            • Re: lldb error import six
              goodcyg Level 1 Level 1 (0 points)

              hello,macOS Mojave 10.14.6,xcode10.2.1,My mac has xcode and python2 installed, python3.

                • Re: lldb error import six
                  eskimo Apple Staff Apple Staff (12,735 points)

                  Does LLDB behave itself when you invoke it from Xcode?  That is, if you create a new Mac project and do a Product > Run, does the debugger function?

                  In Terminal, if you do a printenv, do you see anything obvious that might affect the copy of Python running with LLDB (like a PYTHONPATH environment variable pointing)?

                  Share and Enjoy

                  Quinn “The Eskimo!”
                  Apple Developer Relations, Developer Technical Support, Core OS/Hardware
                  let myEmail = "eskimo" + "1" + "@apple.com"