1 Reply
      Latest reply on Dec 24, 2019 12:13 AM by Claude31
      EdwinNorth Level 1 Level 1 (0 points)

        My Assistant Editor always opens header files from the Xcode 11 directory.

        For example, I tried opening the ContentView.swift file associated with my view Object. Instead the Assistant Editor opened a UIViewController.h file, which isn't even in my folder. As far as I understand it, it's a directory issue and I tried to set the file manually but nothing happens. It's like Xcode doesn't let me use anything else than the .h files.

        Any help?










        • Re: Assistant Editor Problem
          Claude31 Level 8 Level 8 (7,845 points)

          I tested with XCode 11.2ß2, selecting a controller in IB and then call Assistant via the menu.

           

          It opens the right file.

           

          But there have been a few threads on this.

          https://forums.developer.apple.com/message/387103#387103

          What you may have to do is select the "Navigate to related items" at the top left of the canvas window (icon shows 2 small stacked rectangles) and select top level.

          Or, in the code window displayed next to the IB Canvas, click on Automatic (in the top bar) and select Top Level Objects.