2 Replies
      Latest reply on Feb 13, 2020 12:40 PM by aerciyas
      maybebtc Level 1 Level 1 (0 points)

        Xcode 10.x.x cannot build a Swift 3.x iOS application.

         

        Xcode 9.x.x is required to perform the conversion away from Swift 3.x.

         

        Xcode 9.x.x is not compatible with Catalina 10.15.2.

         

        I am unable to locate installers for previous versions of macOS. Additionally, the hardware is a 16-inch MacBook Pro which, if I understand correctly, cannot run Mojave.

         

        What is the present-day best practice for performing a Swift 3.x conversion from the 16-inch MacBook Pro?