0 Replies
      Latest reply on Nov 30, 2019 10:25 AM by benbritten
      benbritten Level 1 Level 1 (0 points)

        hello!

         

        for the last 24 hours or so we have been unable to validate our mac app store .pkg.  using altool --validate-app, we get this error:

         

        2019-11-27 09:21:49.198 altool[72008:2019928] *** Error: Unable to validate archive '<our package file>.pkg': (

            "Error Domain=ITunesConnectionOperationErrorDomain Code=1095 \"Unable to process app at this time due to a general error\" UserInfo={NSLocalizedRecoverySuggestion=Unable to process app at this time due to a general error, NSLocalizedDescription=Unable to process app at this time due to a general error, NSLocalizedFailureReason=App Store operation failed.}"

        )

         

        we were able to upload the day previously with the exact same build pipeline (so nothing has changed in terms of the various plists/entitlements/code signing) This is a unity game, so the only thing that changed was some very minor content. the iOS and tvOS versions uploaded fine.

         

        I tried just going right to --upload-app without validating and it returned 'uploaded with no errors' but the pkg never arrived on the app store connect activity list.  That was about 24 hours ago, and it stil has not shown up.  But any attempts to upload it again give me the 'redundant bundle version' error, so that package is in the pipe somewhere.

         

        We bumped the version number and rebuilt from scratch and tried it all again this morning, same issues.  Validate returns 'general error' but the upload works without a problem, and now a few hours later, still no package on the Activity tab on App Store Connect.

         

        I am at a loss here, we have been submitting without issue for months now, and none of the things that usually cause odd errors (icons, plists, entitlements, certs, cfbundleids, etc) have changed at all.  Hopefully someone has some idea?

         

        Thanks!

        Ben