1 Reply
      Latest reply on Nov 21, 2019 2:33 AM by gtufano
      gtufano Level 1 Level 1 (0 points)

        I have an app, currently on the store as a _normal_ AppKit Macintosh build. I made a Catalyst port of the iOS app after a significant rewrite (it was easier, and it's an audio player app so not critical on UI). The app already required manual signing in the iOS part because CarPlay, so I just followed the help instructions in xcode to change the Catalyst app application id so to have the same ID as the existing app store app.

        All worked, certificates has been created, a notarized version works correcty.

        I'm not able to sign the application for Mac App Store Distribution.

        I made an archive for macOS app, select distribute, but the profiles for the Catalyst app are not available. I just see the distribution profiles for the "old" AppKit application, marked as "not eligible" (selecting them in Xcode signing section I see errors on the lines of "Provisioning profile "XXXXX" doesn't support the App Groups and Siri capability.", and there is no Siri capability for "normal" mac apps.

         

        I'm stuck. The Distribution section of Xcode Organizer do not recognize profiles made for the Catalyst app (probably because the "original" bundle identifier for the iOS app is different) and the profiles made for the AppKit bundle ID don't support capabilities that the iOS app has.

         

        I think this is an Xcode bug, but I'm unsure of everything and I could be failing on something basic. I could just distribute the app myself (notarization works) but I'd like to substitute the current app in the store (and would like to not add updating tools to the app).

         

        Any help/hint would be appreciated, thank you!

        • Re: Problems substituting an existing Mac App Store build a with Catalyst build
          gtufano Level 1 Level 1 (0 points)

          I think this is an Xcode bug. The same error (no distribution profile) now happens also with notarization only (same certificates and profile used another time). If I manually import the profile in the "select certificates and Mac App Store profiles" stage of application upload I import a profile for the iOS/Catalyst app, the process works.

          On the previous case, improting manually a profile for the app store also continue the process, but the submission is refused because "the app is not sandboxed" (thing of course false, Catalyst apps are sandboxed by default).

          Anyway, I filed feedback FB7459218 in case someone from Apple is looking at the problem.