3 Replies
      Latest reply on Dec 3, 2019 11:51 PM by Defa
      SMA Level 1 Level 1 (0 points)

        Does anyone know how to get past this error. I have not been able to run my app on device for days.

         

        Unable to install "Hello World"
        Domain: com.apple.dtdevicekit
        Code: -402653172
        --
        App installation failed
        Domain: com.apple.dtdevicekit
        Code: -402653172
        Failure Reason: The operation timed out.
        User Info: {
            DVTRadarComponentKey = 487927;
            "com.apple.dtdevicekit.stacktrace" = (
          0   DTDeviceKitBase                     0x000000012616c6e7 DTDKCreateNSError + 109
          1   DTDeviceKitBase                     0x000000012616cde9 DTDK_AMDErrorToNSError + 792
          2   DTDeviceKitBase                     0x00000001261ac56a __90-[DTDKMobileDeviceToken installApplicationBundleAtPath:withOptions:andError:withCallback:]_block_invoke + 164
          3   DVTFoundation                       0x000000010d447156 DVTInvokeWithStrongOwnership + 73
          4   DTDeviceKitBase                     0x00000001261ac301 -[DTDKMobileDeviceToken installApplicationBundleAtPath:withOptions:andError:withCallback:] + 1589
          5   IDEiOSSupportCore                   0x0000000126034a25 __118-[DVTiOSDevice(DVTiPhoneApplicationInstallation) processAppInstallSet:appUninstallSet:installOptions:completionBlock:]_block_invoke.352 + 4523
          6   DVTFoundation                       0x000000010d5783ba __DVT_CALLING_CLIENT_BLOCK__ + 7
          7   DVTFoundation                       0x000000010d579a92 __DVTDispatchAsync_block_invoke + 809
          8   libdispatch.dylib                   0x00007fff64f00583 _dispatch_call_block_and_release + 12
          9   libdispatch.dylib                   0x00007fff64f0150e _dispatch_client_callout + 8
          10  libdispatch.dylib                   0x00007fff64f06ace _dispatch_lane_serial_drain + 597
          11  libdispatch.dylib                   0x00007fff64f07452 _dispatch_lane_invoke + 363
          12  libdispatch.dylib                   0x00007fff64f10a9e _dispatch_workloop_worker_thread + 598
          13  libsystem_pthread.dylib             0x00007fff6515e71b _pthread_wqthread + 290
          14  libsystem_pthread.dylib             0x00007fff6515e57b start_wqthread + 15
        );
        }
        
        • Re: How do I get past a "App installation failed" (com.apple.dtdevicekit) error
          ankit001 Level 1 Level 1 (0 points)

          same issues any solutions

            • Re: How do I get past a "App installation failed" (com.apple.dtdevicekit) error
              sdevo619 Level 1 Level 1 (0 points)

              Restarting Devices seemed to temporarily allow me to actualty install the Watch App, but I cant tell you the order in which I performed these tasks that is actually worked. It is a crapshoot as far as I can tell.

               

              I have sent two reviews of this build of XCode to Apple regarding this specific issue already too. This build of XCode is an abomination to put it as nicely as I can. Running a WatchOS app on device has now become such a time ****, that it is no longer even viable to create a WatchOS app. Apple's inabilty to make their own software run relaibly enough to even allow developers to log and test on Apple Watch, is a very clear indicator of where things are headed at Apple right now. Can anyone confirm if the newest XCode beta for devs, fix this??? I'm running 11.2.1

               

              XCode is getting more broken with every single release now too. Time and time again, in this last year, I keep finding myself, having to install beta builds of Apple's own software to fix the enoumous messes, that their quality contol teams, or lack there of, keep making. I could not even scroll the app review textView in the Mac App Store, which is a glalringly obvious issue for trying to type of a thorough review of any app. This is again a clear indicator of how little attention is being paid to MacOS or detail in general as whole right now at Apple.

               

              I also happen to work with my own customers daily troublshooting tech for them, and iOS 13 has been the primary source of probelms and complaints I am hearing from my own customers as well. The general concesus, is that nothing works reliably, and while I wish my own experience, with my knowledge base I have, as someone who has been developing iOS apps for over 5+ years and building computers for over 20 years, was different, I feel the exact same way as them.

               

              Apple, if you dont hire better people to do Quality Control on your software, stop releasing beta builds as final releases, and start listening to both your customers, and more importantly in this instance, your developers, as this one issue, has pretty much made testing impossible on WatchOS until it is fixed, you are going to find, that people continue to turn on you and your brand.

               

              Stop trying to do everything and cannabilizing the entire tech industry, maybe focus on doing what you used to actually be good at. Making products that people love to use. My iPhone 11 "Pro", doesnt even turn on of off properly, and I am constally having to press the power button twice to get it to turn on, which has been there since I purchased the device, so these issues are not just software related, and as I am now having to reboot all my devices daily multiple times, because of all the bugs, I have had it up to here with this nonsense. This plague is impacting every single one of your products.

               

              This one particular issue, is sucking up at least 30 mins of every day now. I spend the better part of my day, each day I work on the WatchOS app for my app, trying my hardest to not chuck this garbage computer out a window. Interestingly enough running on device with iOS works well most of the time, however in this build of XCode, I frequently have to build and run twice before logging starts to work too, which is another bug too. On top of needing to literally reboot my iOS and Watch OS and Mac OS devices multiple time a day now to get things to compile and run, XCode regaurly crashes out the Thunderbold drivers on my computer too, which turns my external monitor pink. This began after upating to Catalina. Catalina also constaly drops connection to my Apple Watch too, which probly where you need to start to fix this utter garbage.

               

              I didn't want to write all this here, or at all, but Apple is putting out such trash right now, that even a dev like me, who is building for iOS and Watch OS daily, who has Steve Jobs book on my shelf, is utterly embarassed by what I am seeing coming out of there right now. It is never too late to change, but hiring more people who are willing to tell you the truth about where your products stand and where they need a lot more work, is something I would be sinking a lot more money into, because this is embarassing. Either that, or you can just keep hiring more customer service reps to put out all the huge fires you keep starting everywhere. My own personal list of known major issues with all your OS's is currently multiple pages long. Time to get on it!!!!!!

              • Re: How do I get past a "App installation failed" (com.apple.dtdevicekit) error
                Defa Level 1 Level 1 (0 points)

                Restarting the device fixed it for me.