3 Replies
      Latest reply on Nov 7, 2019 2:13 PM by Claude31
      christiannc Level 1 Level 1 (0 points)

        It’s hard to explain, but once I added a connection from my sign in button to my sign in screen the notch area on the storyboard isn’t shown anymore, now it’s the sign in page, and there appears to be a white page in the background at the top of this page with the notch now being blacked out. When I run this in storyboard some of the text fields are missing and aren’t formatted correctly. I know that was a lot, but has anyone else had this problem/know how to fix it?

        • Re: Simulator changing storyboard
          Claude31 Level 8 Level 8 (6,905 points)

          So, you have 2 VC:

          - A: the VC with the sign in button

          - B: the VC for sign screen

           

          Exact ?

           

          You said:

          the notch area on the storyboard isn’t shown anymore

          • On which VC: A or B or A & B ?
          • How is the transition defined ? show ? Modally ? Popover ?
          • Is transition defined as Automatic or did you set it Fiull Screen (you should try)

           

          When I run this in storyboard some of the text fields are missing and aren’t formatted correctly

          • What do you mean "run in storyboard" ? Do you mean on simulator ?
          • Some are missing: can you specify which ? Are they hidden by the blank background (could try to change its color to red or grey for test)
          • Not formatted correctly: how incorrect precisely ?

           

          Could you post the whole code of VC A ?

            • Re: Simulator changing storyboard
              christiannc Level 1 Level 1 (0 points)

              The notch area wasn't shown anymore after I added that connection between the VC with the button that took you to the sign up VC and the sign up VC. I fixed that by adding the navigation bar and remaking my stack view on VC B.

               

              I meant run simulator, but there are four text fields in my stack view for VC B; first name, last name, email, phone number, and password. Additionally there is a button that says "Sign Up." The first name and last name text fields were shows in the simulator just fine, but the phone number field was made smalled than its original height of 50. I'm not exactly sure how I fixed this problem, but like I said, I rebuilt my stack view for this VC and now it functions like it should in the simulator except for the notch area is still not shown anymore, but at least everything is formatted as it should be.

               

              If you have any tips for what could have gone wrong or why the notch area isn't showing right now I'll be glad to hear them. I've only been using Xcode for a few days and so I'm still getting used to everything. (Also, I tried getting the code for VC A but the assistant isn't letting me access it right now)

                • Re: Simulator changing storyboard
                  Claude31 Level 8 Level 8 (6,905 points)

                  When you say notch area is not shown, is it because it is surrounded by a black background which makes it invisible or is it because it is covered by a non black content ?

                   

                  Are you running simulation on iPhone X or iPhone 11 simulator (what is the selected device at the very top left of XCode window) ? Otherwise, there is no notch.