7 Replies
      Latest reply on Nov 4, 2019 10:38 PM by Claude31
      uncletr Level 1 Level 1 (0 points)

        Why is my post stuck in DRAFT for 24 hours with the following statement:

         

          "Please note: your content was added successfully, but a moderator needs to approve it before it can be posted"

         

        https://forums.developer.apple.com/thread/125251

         

        Someone replied to it, however, I cannot add a reply to it myself.  I receive the following:

         

          "Sorry, but you are not authorized to reply to this discussion."

        • Re: My post
          KMT Level 9 Level 9 (15,215 points)
            • Re: My post
              uncletr Level 1 Level 1 (0 points)

              Well, I looked through my DRAFT post and there are no hyperlinks including, no offensive words, etc.   but it is still in DRAFT status waiting for a moderator.  Oh well.  I do not know what else to do .  :>P

                • Re: My post
                  Claude31 Level 8 Level 8 (7,255 points)

                  Are you sure there was no hyperlink (not necessarily an explici h ttp, but an embedded link) ?

                   

                  Effectively, we cannot see your post.

                  • Re: My post
                    KMT Level 9 Level 9 (15,215 points)

                    How long is it? Lots of code, strings, phone numbers, random numbers....?

                      • Re: My post
                        uncletr Level 1 Level 1 (0 points)

                        My "other" post is provided beneath the "-----------------" line below.  It is provided so you can read through it and try to help me understand what in the content is causing it to be stcuk in DRAFT status for moderator approval.

                         

                        NOTE: This specific post is now waiting for a moderator to approve it as well  <roll eyes>  :>P

                        ** I will not be surprised if I can no longer reply to this thread if you reply.  The same thing occurred in my "other" post (ie: I cannot reply to it as I no longer am allowed)

                         

                        ----------------------------------------------------

                         

                        I have two buttons of the same size (ie: Button1 and Button2).  Button2 overlaps Button1 by 50% (see below).

                         

                        <manual diagram removed>

                         

                        If I click anywhere within Button2 then I receive an IBAction Click notification from Button2, as expected.

                        If I click anywhere within Button1 then I receive an IBAction Cick notification from Button1, as expected.

                         

                        Issue

                        If Button2 is now disabled (ie: Button2.isEnabled = false) or user interaction set to false (ie: Button2.isUserInteractionEnabled = false) and I click on the left 50% of Button2 area (ie: the area which is overlapping Button1), then I will receive an IBAction Click notification from Button1

                         

                        Questions

                        Why do I receive an IBAction Click notification from Button1 when clicking disabled Button2 ?

                         

                        I would expect not to receive any IBAction Click notifications when clicking anywhere within the area of Button2

                         

                        I think I can work around this issue in code, however, I was wondering whether this is normal handling and how others might resolve this behavior.

                          • Re: My post
                            KMT Level 9 Level 9 (15,215 points)

                            As I note in FAQ 1 at my 'for best results' thread:

                            • Appears that new users are subjected to tighter spam filters

                             

                            How many posts have you made here in devForums, so far?

                             

                            I'd guess the mod flag has something to do with the 'removed' diagram.

                            • Re: My post
                              Claude31 Level 8 Level 8 (7,255 points)

                              I see the other post with the 2 buttons questions (as well as my answer).

                               

                              Did it answer your question ?