3 Replies
      Latest reply on Oct 17, 2019 11:27 PM by ystsoi
      AgentFriday Level 1 Level 1 (0 points)

        Recently upgraded to iOS 13 on an iPad I use for testing my app.  The app build I had previously installed on that iPad ran fine, except that the text on one of my buttons was misplaced, and overlapping the image.  Still not sure why (I didn't get that far).

         

        I went to debug it, and was forced to upgrade Xcode from 10 to 11, so it could talk to iOS 13.  But when I rebuilt the app using Xcode 11.1, and ran it on iOS 13, I ran into MAJOR problems.

         

        1) First, the sign-in screen no longer takes up the full screen, but shows up in a square that can be discarded by swiping down.  Once that happens, I can't get it back without killing the app and restarting.

         

        2) Tapping on the app icon in the dock no longer starts the app or brings it up if it's been minimized.  I have to find the icon on the home screen and use that one.

         

        3) Everything I type into the text edit fields seems to show up (or rather, not show up) in white on white, so that's fun.

         

        4) If I enter my login and password, the request sent to the server fails with error -1002 (unsupported URL), even though as far as I can tell the url passed to NSMutableRequest.requestWithURL is valid.  When I run the same build on iOS 12, it works fine.  If I set a breakpoint in didFailWithError, the url inside of the tconnection parameter is (null)... (???)

         

        I have never had so much trouble with an iOS update breaking our app.  The build created with Xcode 10 runs fine (on either iOS 12 or 13), and the builds I create with Xcode 11.1 run fine on iOS 12.  But if I build with the latest Xcode and run on the latest iOS, it's all sorts of broken.

         

        Any ideas what could be going wrong?  Are there new-fangled features I could opt out of until they are debugged?  I didn't really find any developer instructions for changes you would need to make for your app to work with the new iOS version or Xcode, so it seems like it should just work still.