4 Replies
      Latest reply on Oct 12, 2019 12:47 PM by jmroz51
      jmroz51 Level 1 Level 1 (0 points)

        I have been working on an app that plays short wav files. It was working just fine until recently. Now it works on the simulator, but when I send it to my device to try and run it I get this error message Thread 1: EXC_BAD_ACCESS (code=1, address=0x48). I cannot find anything to help me fix this please help.

        • Re: Error message help...Thread 1: EXC_BAD_ACCESS (code=1, address=0x48).
          eskimo Apple Staff Apple Staff (12,015 points)

          This is a memory access exception, suggesting that you have a memory management problem.  My recommendation is that you deploy the Standard Memory Debugging Tools.

          If that doesn’t help, please post a full Apple crash report, using the <> button to format it as code.

          Share and Enjoy

          Quinn “The Eskimo!”
          Apple Developer Relations, Developer Technical Support, Core OS/Hardware
          let myEmail = "eskimo" + "1" + "@apple.com"

            • Re: Error message help...Thread 1: EXC_BAD_ACCESS (code=1, address=0x48).
              jmroz51 Level 1 Level 1 (0 points)

              Unfortunately I am really new to xcode. I am self taught from youtube and books, so it may be a while before I can understand how to run a Standard Debugging on the app. I looked at several videos and ran my app and saw as it crashed it was running at just over 25MB of memory. I don't understand why it worked so well for a. couple of months and then just started to give me this error message this week.

              I will keep trying, it takes a long time for me to give up, but I really hope I can get this working thanks to help from people like you!

              I really appreciate your answering my question!

                • Re: Error message help...Thread 1: EXC_BAD_ACCESS (code=1, address=0x48).
                  szymczyk Level 2 Level 2 (90 points)

                  Set an exception breakpoint in Xcode using the breakpoint navigator, which you can reach by pressing Cmd-8. By setting an exception breakpoint, when your app crashes, Xcode will stop at the point of the crash so you can find where the crash occurs. If you need additional information on Xcode's debugger, read the following article:

                   

                  swiftdevjournal.com/an-introduction-to-xcodes-debugger/

                   

                  You're going to have to copy and paste the article URL to read the article. These forums put posts with external links into moderation for days.

                    • Re: Error message help...Thread 1: EXC_BAD_ACCESS (code=1, address=0x48).
                      jmroz51 Level 1 Level 1 (0 points)

                      I have been trying and searching for debugging information with the suggestions you guys gave me until my head hurt. I kept wondering why it work with NO issues before and now even the simulator will not load the app. I thought of what was different since the last time it worked. I was on xcode 10.3 and my phone was using iOS 12.4!

                      I found and reinstalled xcode 10.3 and used my daughters iPad, which was not updated, and when I installed my app it again worked perfectly.

                      So somewhere in xcode 11 or iOS 13.1 is the problem. I don't know how to fix that, but I may just look to see how I can get my phone back to 12.4 and just leave it that way.

                      It appears that another upgrade was rolled out BEFORE all of the aspects of defects was looked at.

                       

                      Again, I thank you guys for your assistance and giving me a better idea of debugging and understanding crash codes.