4 Replies
      Latest reply on May 18, 2020 2:26 AM by tszpan
      patniemeyer Level 1 Level 1 (0 points)

        When I attempt to launch an app from Xcode 11 (gm seed 2) to my attached iPhone running iOS 13 the I see the app launch with a white screen but then the iOS process hangs for about *60 seconds* before the app finishes launching.  If I un-check "debug executable" on the target then this behavior does not happen.  If I launch the app on the phone directly (without xcode) it launches normally.  If I launch the app on the phone and attempt to attach the debugger from xcode I get the same (one minute) hang.

         

        This only happens on one of my machines even though both are using the same setup (only diff is that one is a laptop and one is a desktop).  So I am assuming something is wrong or corrupted with the "debug support" that was installed on first connect to the new xcode...  But I can find no reference to how to re-init that.  I have tried the "unpair phone" option in devices in xcode but it does nothing.  I don't see anything in settings related to developer profiles or debug symbols.

         

        Anything I can do to reset the phone with respect to debgging support / symbols installed by xcode?  Any other thoughts?

         

        thanks,

        Pat

        • Re: Xcode 11 hangs while attaching debugger to ios process
          patniemeyer Level 1 Level 1 (0 points)

          UPDATE: This is happening on that machine even when targeting a new phone and with a fresh install of XCode 11!  It must be something hosed in the environment...  What outside of xcode could be involved with this?  Bear in mind that it's not broken - just takes *60 seconds* to attach the debugger.

            • Re: Xcode 11 hangs while attaching debugger to ios process
              muva90 Level 1 Level 1 (0 points)

              I'm facing the same issue now. Did you resolve the issue patniemeyer?

               

              This happens:

              • only on my iMac and iPhone 11pro combination, it doesn’t happen if I build on another macbook or if I try it with another phone
              • for any app, even the newly create sample app
              • only if “Debug executable” is turned on in edit scheme, and if I just run the app from the homescreen it’s fine

              What I tried already:

              • deleting derived data ofc
              • restarting the phone
              • restarting iMac
              • reinstalling Xcode
              • clearing trusted computers from the phone
            • Re: Xcode 11 hangs while attaching debugger to ios process
              chakiralu Level 1 Level 1 (0 points)

              Hi! I was suffering from the same problem.

              My development environment is as follows.

              Xcode 11.3.1, iPhone 7 iOS 13.3.1, MacBook Pro (2016) macOS Catalina version 10.15.3

              I was able to solve it in the following way.

              1. Quit Xcode.

              2. Open the Mac desktop application Terminal.app.

              3. Execute command "rm -rf ~/Library/Developer/Xcode".

              4. Open Xcode.

              5. Select the Xcode menu "Product - Scheme - Edit Scheme".

              6. Check the "debug executable" in "Run - Info"

              7. Then I was able to debug.

              thanks.

              • Re: Xcode 11 hangs while attaching debugger to ios process
                tszpan Level 1 Level 1 (0 points)

                I encountered the same problem today.

                Environment:

                Xcode 11.4.1, Mac mini 2018, macOS Catalina 10.15.3,

                tested with two iPhone 6(both are iOS 12.4.6), they have this problem too(but not in every launch),

                also tested with an iPhone 8+, which doesn't have this problem at all

                 

                I deleted folders inside ~/Library/Developer/Xcode/iOS DeviceSupport/ (folder's name started with 12.4.6), then run Xcode and launch an app again, problem solved.

                 

                What a weird bug...