2 Replies
      Latest reply on Sep 25, 2019 11:37 AM by Edsson
      FishOSU Level 1 Level 1 (0 points)

        I've got two problems with Xcode 11 GM:

         

        1. Whenever I upload my app that contains a sticker extension, App Store Connect yells at me: WARNING ITMS-90747: "Architecture incompatible with MinimumOSVersion. The app bundle at 'Ohio State.app/PlugIns/Ohio State Stickers.appex' specifies a MinimumOSVersion of '13.0' but contains a 32-bit architecture that is unsupported on iOS 12 and later."

         

        I don't see how this is possible from my configuration. It's set the same way as our other application extensions and they generate only for arm64. For some reason the sticker pack includes armv7, armv7s, and arm64.

         

        2. I can no longer select the messages extension app icon from the project navigator view. The value from Xcode 10 is in there still, but it's red and the drop down for App Icons Source doesn't even list the asset catalog that contains the icon. It appears to only be looking for standard iOS icons now.

         

        At this point I guess I'm going to be releasing our iOS 13 update with broken sticker apps unless anyone has a solid idea on how to fix this.